Bug 454504 - Update from kernel 2.6.25-6-55 to 2.6.25-9-76 breaks wireless connectivity
Update from kernel 2.6.25-6-55 to 2.6.25-9-76 breaks wireless connectivity
Status: CLOSED DUPLICATE of bug 453390
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-08 17:12 EDT by Ed Schofield
Modified: 2008-07-08 19:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 19:06:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant sections from /var/log/messages when booting from each of the -6-55 and -9-76 kernels and establishing a wireless connection with NetworkManager (or not) (14.83 KB, application/x-bzip)
2008-07-08 17:12 EDT, Ed Schofield
no flags Details

  None (edit)
Description Ed Schofield 2008-07-08 17:12:46 EDT
Description of problem:

NetworkManager can no longer connect to my home wireless network after the
latest kernel update in Fedora 9. Booting with the previous 2.6.25-6-55 kernel
allows NetworkManager to establish a connection with my RaLink wireless card,
while booting with the newer 2.6.25-9-76 kernel does not.

How reproducible:

Always.


Additional info:

lspci -v shows my wireless card as:

04:00.0 Network controller: RaLink RT2561/RT61 802.11g PCI
        Subsystem: Giga-byte Technology GN-WP01GS
        Flags: bus master, slow devsel, latency 64, IRQ 16
        Memory at ff7f8000 (32-bit, non-prefetchable) [size=32K]
        Capabilities: [40] Power Management version 2
        Kernel driver in use: rt61pci
        Kernel modules: rt61pci

Snips of the relevant sections in /var/log/messages are attached, showing the
difference between booting with the older versus the newer kernel. In short, the
supplicant connection continues changing state with the newer kernel, and the
message

avahi-daemon[1995]: Registering new address record for fe80::216:e6ff:fe3b:10ec
on wlan0.*.

appears instead of

NetworkManager: <info>  (wlan0): supplicant connection state change: 6 -> 7
NetworkManager: <info>  Activation (wlan0/wireless) Stage 2 of 5 (Device
Configure) successful.  Connected to wireless network 'myssid'.

If there are any more diagnostics I can do to help to pinpoint this bug, please ask.
Comment 1 Ed Schofield 2008-07-08 17:12:46 EDT
Created attachment 311315 [details]
Relevant sections from /var/log/messages when booting from each of the -6-55 and -9-76 kernels and establishing a wireless connection with NetworkManager (or not)
Comment 2 Yanko Kaneti 2008-07-08 18:13:41 EDT
dup of bug 453390
Comment 3 Dave Jones 2008-07-08 19:06:49 EDT

*** This bug has been marked as a duplicate of 453390 ***

Note You need to log in before you can comment on or make changes to this bug.