Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 454551 - New specs for Service Breach Time Calculations
Summary: New specs for Service Breach Time Calculations
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Gatekeeper
Version: 1.3.9
Hardware: All
OS: All
high
high
Target Milestone: ---
: ---
Assignee: JBoss CSP Bug Watch List
QA Contact:
URL:
Whiteboard:
: 454717 (view as bug list)
Depends On:
Blocks: 457070
TreeView+ depends on / blocked
 
Reported: 2008-07-08 21:52 UTC by Mike Amburn
Modified: 2009-02-09 21:07 UTC (History)
2 users (show)

Fixed In Version: MR8-CSP
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-30 20:24:06 UTC
Type: ---


Attachments (Terms of Use)

Description Mike Amburn 2008-07-08 21:52:56 UTC
There are four situations when SBT notifications should be sent to JBoss Support.
case status is NEW and Threshold Time is reached
case status is NEW and Breach Time is reached
case status is WORH and Threshold Time is reached
case status is WORH and Breach Time is reached

Service Breach Time notifications
These four situations need to be managed by four different rules in GateKeeper because we need the ability to turn on or off these four rules independently from each other.

Values of Threshold time according to Initial Response Time
Initial Response Time | Threshold Time 1 hour | 40 minutes before Breach 2 hours | 40 minutes before Breach 4 hours | 1 hour before Breach 4 business hours | 1 hour before Breach 24 hours | 4 hours before Breach 1 business day | 4 hours before Breach 2 business days | 12 hours before Breach

***These values should be configurable, so that we can easily change Warning Threshold Times in the future
*** Either through a ui, or deployable drools file. Value of the Subject field in the email template 

The template is the same for the 4 situations mentioned above, EXCEPT for the Subject of the email Case status is NEW and Threshold Time is reached [I-T group]-[tid] : NEW Case - IMPENDING SLA BREACH - [case summary] Case status is NEW and Breach Time is reached [I-T group]-[tid] : NEW Case - BREACHED SLA - [case summary] Case status is WORH and Threshold Time is reached [I-T group]-[tid] : WORH Case - IMPENDING SLA BREACH - [case summary] Case status is WORH and Breach Time is reached [I-T group]-[tid] : WORH Case - BREACHED SLA - [case summary]

Email template
-------------------------------------------------------------
From: no-reply@redhat.com
To: [I-T user's email address]
Subject: [Depends on specific case situation - See section above]

Case Url: [link to case]
Case Number: [tid]
Severity: [case severity]
Service Breach Time: [Service Breach Time]
Contact Name: [name of person who opened the case]
Case Company: [company name]
Contact Phone: [contact phone of person who opened case]
Customer Email: [email address of person who opened case]
Case assigned to: [name of the case owner] and, if not = 'not assigned yet'
Product Selected: [product]
Version Selected: [version]
Module Selected: [module]
Case Summary: [case summary]
Case Description: [Full case description] -------------------------------------------------------------

----
Data relocated from Jira (JBNET-2260)

Comment 1 Nathan Lugert 2008-08-28 13:06:17 UTC
*** Bug 454717 has been marked as a duplicate of this bug. ***

Comment 2 Nathan Lugert 2009-02-09 21:07:00 UTC
implemented new SLA breach specifications. Threshold can be set without re-deploy of Gatekeeper as they are JBPM variables. I set SLA breach threshold times to that of the description. 

Also, updated the impending SLA Breach email notification template to match the one in the description.


Note You need to log in before you can comment on or make changes to this bug.