Bug 454586 - Please backport ProxyPassMatch to RHEL5 httpd
Please backport ProxyPassMatch to RHEL5 httpd
Status: CLOSED DUPLICATE of bug 449159
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-09 01:33 EDT by Binand Sethumadhavan
Modified: 2008-07-09 04:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 04:43:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Binand Sethumadhavan 2008-07-09 01:33:58 EDT
Description of problem:
ProxyPassMatch directive is implemented in Apache 2.2.5. Please see if it is
possible to backport this directive to RHEL5's 2.2.3 Apache.

Version-Release number of selected component (if applicable):

httpd-2.2.3-11.el5_1.3

How reproducible:

Always

Steps to Reproduce:
1. Edit httpd.conf to include a ProxyPassMatch directive (eg: ProxyPassMatch
^(/.*\.jsp)$ ajp://localhost:8009$1)
2. Reload httpd (sevice httpd reload)
3. Error logged.
  
Actual results:

Syntax error on line 25 of /etc/httpd/conf.d/proxy_ajp.conf:
Invalid command 'ProxyPassMatch', perhaps misspelled or defined by a module not
included in the server configuration

Expected results:

Normal reload of Apache

Additional info:

The configuration directive is needed for connecting Apache to Tomcat. There is
a workaround using mod_rewrite rules, though (but that requires a different
module to be loaded into Apache)
Comment 1 Joe Orton 2008-07-09 04:43:49 EDT
Thanks for the report.  Yes, this is already proposed for inclusion in 5.3.

*** This bug has been marked as a duplicate of 449159 ***

Note You need to log in before you can comment on or make changes to this bug.