Bug 454663 - mkinitrd missing scsi_wait_scan
mkinitrd missing scsi_wait_scan
Status: CLOSED DUPLICATE of bug 470628
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
10
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-09 11:38 EDT by Doug Chapman
Modified: 2008-12-09 15:00 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 15:00:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Correct variable name (495 bytes, patch)
2008-12-08 18:42 EST, Nate Clark
no flags Details | Diff
Corrected all variable names (682 bytes, patch)
2008-12-09 01:24 EST, Nate Clark
no flags Details | Diff

  None (edit)
Description Doug Chapman 2008-07-09 11:38:29 EDT
Description of problem:
Recent mkinitrd no longer adds these lines to the init script:

modprobe scsi_wait_scan
rmmod scsi_wait_scan

also does not appear to be pulling in scsi_wait_scan at all.

This breaks booting on scsi.


Version-Release number of selected component (if applicable):
mkinitrd-6.0.54-1.fc10

testing 6.0.55 now but based on the changelog it does not appear this is fixed.


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-07-09 13:35:19 EDT
I confirmed mkinitrd-6.0.55-1.fc10 does still have this issue.
Comment 2 Jeremy Katz 2008-07-09 14:17:55 EDT
This is because scsi_mod is now built-in and that was what we used to key
needing scsi_wait_scan
Comment 3 Dave Jones 2008-07-09 19:24:55 EDT
ah, good catch.
I could flip this back to =m if there's no better way.
Strikes me as somewhat fragile to do it this way, though I admit I haven't got
any better ideas.
Comment 4 Jeremy Katz 2008-07-09 19:41:39 EDT
I guess we could try to do some form of determination based on symbols used in
the module, but then we have to be doing nm on modules.  Or we could use the
modules.block file and seeing if the driver is listed there

Comment 5 Bug Zapper 2008-11-25 21:32:05 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Nate Clark 2008-12-08 18:42:11 EST
Created attachment 326229 [details]
Correct variable name

There is some code in there to wait for scsi to stop scanning it doesn't use the module but it would work if the variable name was consistent.
Comment 7 Nate Clark 2008-12-09 01:24:43 EST
Created attachment 326270 [details]
Corrected all variable names

Last suggested patch made things worse this one makes all variables the same name.
Comment 8 Dave Jones 2008-12-09 15:00:30 EST

*** This bug has been marked as a duplicate of bug 470628 ***

Note You need to log in before you can comment on or make changes to this bug.