Bug 454707 - iwl4965 doesn't works unde rhel5.2 x86_64
iwl4965 doesn't works unde rhel5.2 x86_64
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iwl4965-firmware (Show other bugs)
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: John W. Linville
Depends On:
  Show dependency treegraph
Reported: 2008-07-09 16:20 EDT by Carlos Lopez
Modified: 2008-07-14 13:22 EDT (History)
0 users

See Also:
Fixed In Version: iwl4965-firmware-
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-07-10 09:26:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshoot (199.49 KB, image/png)
2008-07-11 10:54 EDT, Carlos Lopez
no flags Details

  None (edit)
Description Carlos Lopez 2008-07-09 16:20:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061517 Red Hat/3.0-2.el5 Firefox/3.0

Description of problem:
When i try to load iwl4965 driver using modprobe doesn't works. I have verified that it isn't blacklisted under /etc/modprobe.d like in rhel5.0.

Version-Release number of selected component (if applicable):
iwl4965-firmware-4.44.17-1.noarch and kernel-2.6.18-92.1.6.el5.x86_64

How reproducible:

Steps to Reproduce:
1.modprobe iwl4965
2.insert "alias wlan0 iwl4965" in modprobe.conf

Actual Results:
Doesn't works and returns this error:

iwl4965: Intel(R) Wireless WiFi Link 4965AGN driver for Linux, 1.2.22ks
iwl4965: Copyright(c) 2003-2007 Intel Corporation
iwl4965: Detected Intel Wireless WiFi Link 4965AGN
iwl4965: iwlwifi-4965-1.ucode firmware file req failed: Reason -2
iwl4965: Could not read microcode: -2
iwl4965: probe of 0000:03:00.0 failed with error -2

Expected Results:
working wifi

Additional info:
Comment 1 Carlos Lopez 2008-07-09 16:30:05 EDT
As a Sam Sharpe says on rhel5-list:
https://www.redhat.com/archives/rhelv5-list/2008-July/msg00119.html, bug is
solved doing a soflink like this:

ln -s /lib/firmware/iwlwifi-4965.ucode /lib/firmware/iwlwifi-4965-1.ucode

 Can this be fixed in a next release of iwl4965-firmware package??

Comment 2 John W. Linville 2008-07-10 09:26:15 EDT
There alread is a next release of the firmware package.  Please update it from 
the Supplementary CD.
Comment 3 Carlos Lopez 2008-07-10 16:26:10 EDT
Sorry John, but under supplementary channel anly appears same buggy package ...
Comment 5 John W. Linville 2008-07-11 08:49:40 EDT
Others seems to have been able to get it.  What are you doing to attempt the update?
Comment 6 Carlos Lopez 2008-07-11 10:25:23 EDT
I have tried now and I only see previous version ...
Comment 7 John W. Linville 2008-07-11 10:41:45 EDT
Could you be more specific about _what_ you are trying?
Comment 8 Carlos Lopez 2008-07-11 10:54:50 EDT
Created attachment 311590 [details]
Comment 9 Carlos Lopez 2008-07-11 10:56:14 EDT
Yes, as you can see in this attachment, supplementary channel for rhel5 server
x86_64 only shows previous version: iwl4965-firmware-4.44.17-1.noarch
Comment 10 John W. Linville 2008-07-14 11:06:03 EDT
I am told that RHN has resolved the issue regarding availability of that 
package in the proper channel.  Please try the update process again!
Comment 11 Carlos Lopez 2008-07-14 13:22:19 EDT
Many thanks John. I have already downloaded new iwl-firmware package.

Note You need to log in before you can comment on or make changes to this bug.