Bug 454858 - Want "--tree" option or similar to system-install-packages
Want "--tree" option or similar to system-install-packages
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-10 05:04 EDT by Toralf
Modified: 2013-03-12 16:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 16:16:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2008-07-10 05:04:55 EDT
Description of problem:
From the system-install-packages manual page:

Any dependencies will be  resolved  using the  system's  configured  repositories

This is all very fine as a default, but it should also be possible to specify a
directory and/or repository to use for dependency resolution, IMO. After all,
you are installing packages outside of the normal repo config, so it should be
possible to make the setup completely independent of it.

Suggestion: Re-introduce the "--tree" option of the old (anaconda-based)
system-install-packages. This would also resolve some compatibility problems I'm
having with install scripts - they should support RHEL 4 and 5, but I'm not
actually able to write them correctly, since the version 4
system-install-packages pretty much requires --tree, while the new one will
choke on it, but not return an error status or anything. (And there is no easy
way to test version number so that I can select options, either.)


Version-Release number of selected component (if applicable):
1.3.28-13.el5


How reproducible:
Enough said, I think...
Comment 1 James Antill 2013-03-12 16:16:24 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red 
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat 
Enterprise Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in 
response to customer and partner requirements, Red Hat takes a 
conservative approach when evaluating enhancements for inclusion in 
maintenance updates for currently deployed products. The primary 
objectives of update releases are to enable new hardware platform 
support and to resolve critical defects.


You could re-request this kind of feature in RHEL-6 or RHEL-7, as I don't believe we have anything like it with our newer tools.

Note You need to log in before you can comment on or make changes to this bug.