Bug 454876 - if you point to sat hostname without FQDN, logging in redirects to Login.do forever
if you point to sat hostname without FQDN, logging in redirects to Login.do f...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Lestach
wes hayutin
: Triaged
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2008-07-10 10:17 EDT by Máirín Duffy
Modified: 2009-09-10 16:26 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:26:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Máirín Duffy 2008-07-10 10:17:01 EDT
Description of problem:

A frustrating behavior of Satellite for first-time users is that when you try to
visit the Satellite in a webbrowser using just the satellite's hostname (e.g.,
http://my-satellite) it will just redirect to the Satellite's front login screen
no matter how many times you attempt to login. You have to use the
fully-qualified domain name to successfully login.

It should be pretty simple to add a rewrite rule in the default httpd config for
Satellite to redirect to the FQDN?

This would make for a more polished first-time experience for Satellite customers.
Comment 5 Tomas Lestach 2009-04-30 09:41:45 EDT
The origin of the problem was in the cookie generation.

When having satellite "sat.domain.com", created cookie was valid for the whole .sat.domain.com domain (inclusive subdomains). When accessing server only using "sat", domain set for the cookie was ".sat", what is not a valid domain and what's why no cookie was sent in the response. There's no login without a cookie.

Now, no domain is set for the new generated cookie, what causes using of default "host" (sat/sat.domain.com) instead of domain defining cookie validity.

git commit: e9715250fa3d95e562e4357ec712495691e7a66b
tag: spacewalk-java-0.6.9-1
Comment 6 Tomas Lestach 2009-05-11 09:43:51 EDT
Available incomposes since Satellite-5.3.0-RHELx-re20090507.1
Comment 7 wes hayutin 2009-05-11 09:55:08 EDT
this should work as a test..
https://riverraid.rhndev/rhn/YourRhn.do

instead of the additional redhat.com

logs in fine

5/7.1 build
Comment 8 wes hayutin 2009-05-11 14:57:06 EDT
ok.. recreated this on grandprix 5/7.1 build..

I cant login w/ the FQDN now.. however I can login w/ short name..
something is not right..

failing
Comment 9 Tomas Lestach 2009-05-12 04:44:35 EDT
I managed to login into grandprix using following addresses:

https://grandprix.rhndev.redhat.com/
https://grandprix.rhndev/
https://grandprix/

The same into riverraid and 2 of my satellites.


Anyway, I suggest to open a new BZ, if you have trouble logging in using FQDN.
Comment 10 wes hayutin 2009-05-12 09:55:43 EDT
ok.. will do.. 
John Mathews and I both ran into similar problems.  Some how we got satellite into a state where we could not log in.  May be a bad cookie.. who knows..
Comment 12 Brandon Perkins 2009-09-10 16:26:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.