Bug 45488 - Kickstart install fails when using 7.0 bootnet.img connecting to 7.1 Nfs repository
Kickstart install fails when using 7.0 bootnet.img connecting to 7.1 Nfs repo...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-21 21:23 EDT by David Grote
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-06 09:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Grote 2001-06-21 21:23:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
On a 7.1 Redhat Server, set up Repository for 6.2, 7.0, and 7.1 Cds to be 
mounted through Nfs for a kickstart install.  6.2 and 7.1 work find, but 
when using 7.0 bootnet.img to connect to 7.1 hangs at install 
saying "Neighbour table overflow" dont know if this error has any 
relevance.  Overall seems that when using 7.0 bootnet.img to connect to 
7.1 Repository for 7.0 install will not work.  Is there an updated 
bootnet.img or a fix that might get a 7.0 kickstart to work from a 7.1 
server.  We had this same setup on a 7.0 Repository and all three Os 
installed fine.  Why doesn't 7.1 accept 7.0.  Baffling.
Any help would be greatly appreciated.

How reproducible:
Always

Steps to Reproduce:
1. Setup a 7.1 kickstart server to install a 7.0 Redhat Linux distro
2. Using 7.0 bootnet.img and mkkickstart grab and make kickstart boot 
floppy.
3. While connecting using the 7.0 boot floppy to 7.1 repository will hang.
	

Actual Results:  Hangs at Language screen.
In the background says on one terminal that mount was successful.
Says on the other Neighbour table overflow error.


Expected Results:  I believe that since a 7.0 Repository could house 6.2, 
7.0, and 7.1 using all three different os bootnet.img to connect, that 7.1 
should be able to do the same (even more wierd that 6.2 works fine)


Additional info:

If any more information is needed to solve this, Let me know. We have 
reproduced this on several different networks.
Comment 1 Brent Fox 2001-06-26 13:58:50 EDT
I think that there is some incompatibility between the versions of mount and NFS
between 7.0 and 7.1.  I think a potential workaround is to do an FTP or HTTP
install for the affected versions.
Comment 2 Brent Fox 2001-07-06 09:33:41 EDT
You shouldn't see this problem between Red Hat Linux 7.1 and future versions.

Note You need to log in before you can comment on or make changes to this bug.