Bug 45496 - exportfs -u does not work in the following scenario
exportfs -u does not work in the following scenario
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-22 03:59 EDT by aparnakhatri
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-22 10:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aparnakhatri 2001-06-22 03:59:21 EDT
Description of Problem:


How Reproducible:


Steps to Reproduce:
1. exportfs <host1>:<dir> 
2. exportfs <host2>:<dir>
3. exportfs <ip_address_of_host1>:<dir>
4. exportfs -u <host1>:<dir>

Actual Results:
After step 3, all entries for host1 in etab and xtab change to show 
ip_Address instead of fully qualified hostname.
Step 4 fails. Entry is removed from etab, but not xtab.

Expected Results:

After "exportfs -u", entry should have gone from etab and xtab file.
If exportfs replaces hostnames with ip_Address and ip_Addresses with 
hostnames, then exportfs -u, should also be able to work with either.

Additional Information:

Tried exportfs with ip_address, fully quaified domain name and short 
name , but none worked.
If only IP addresses are specified for client name, then everything works 
fine.
Comment 1 Bob Matthews 2001-06-22 11:39:38 EDT
I can not reproduce this problem on a stock 7.1 system.
Comment 2 aparnakhatri 2001-08-22 03:17:21 EDT
Well, I just tried it and I get the same problem.
1. exportfs system1:/tmp
2. exportfs a.b.c.d:/tmp2

where a.b.c.d is ip address of system1.
Now try exportfs -u system1:/tmp - It fails for me.

Note You need to log in before you can comment on or make changes to this bug.