Bug 454977 - Rebase to net-snmp-5.3.2.2
Rebase to net-snmp-5.3.2.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Safranek
: Rebase
Depends On:
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-07-11 04:04 EDT by Jan Safranek
Modified: 2009-01-20 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Net-SNMP has been re-based to upstream version 5.3.2.2. This update adds Stream Control Transmission Protocol (SCTP) support (as per RFC 3873, http://www.ietf.org/rfc/rfc3873.txt) and introduces two new configuration options (to be used in /etc/snmpd.conf): * 'dontLogTCPWrappersConnects' - suppresses logging of connection attempts. * 'v1trapaddress' - enables administrators to set an agent's IP address inside outgoing SNMP traps. This update also features several bug fixes from upstream, including: * The snmpd daemon now functions properly on systems with more than 255 network interfaces. In addition, snmpd also reports an error now when it is configured to listen on any port higher than 65535. * A race condition that caused the snmpd daemon to leak file descriptors when reading from /proc is now fixed. * The snmpd daemon now correctly reports hrProcessorLoad object IDs (OID), even on multi-CPU hardware. Note, however, that it takes approximately one minute from daemon startup to calculate the value of the OID. * The net-snmp-devel package is now dependent on the lm_sensors-devel package.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:07:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
changelog (12.38 KB, text/plain)
2008-07-23 06:09 EDT, Jan Safranek
no flags Details
SVN commit log (3.07 MB, text/plain)
2008-07-23 06:10 EDT, Jan Safranek
no flags Details

  None (edit)
Description Jan Safranek 2008-07-11 04:04:30 EDT
Upstream has released new version in stable 5.3.x branch and we should benefit
from their work (we ship net-snmp-5.3.1, upstream has net-snmp-5.3.2.2).

The rebase does not break API/ABI, customers can use their applications without
recompilation. E.g. I've checked that old net-snmp daemon and utilities work
with new net-snmp-libs without any problems.

Short changelog ("management summary"):
http://net-snmp.svn.sourceforge.net/viewvc/net-snmp/tags/Ext-5-3-2-2/net-snmp/NEWS?revision=17066&view=markup

Longer changelog:
http://net-snmp.svn.sourceforge.net/viewvc/net-snmp/tags/Ext-5-3-2-2/net-snmp/CHANGES?revision=17060&view=markup

SVN Commit log:
http://net-snmp.svn.sourceforge.net/viewvc/net-snmp/tags/Ext-5-3-2-2/net-snmp/ChangeLog?revision=17065&view=markup
Comment 1 RHEL Product and Program Management 2008-07-11 04:20:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Jan Safranek 2008-07-17 06:08:16 EDT
I created preview of rebased net-snmp at
http://people.redhat.com/jsafrane/bugs/454977/. Please distribute it to any
customer who might be interested in testing. Note that the package does not
contain all fixes  scheduled for RHEL 5.3. It's should contain all bugfixes for
RHEL 5.2 and it should not introduce any
regression.https://bugzilla.redhat.com/attachment.cgi?bugid=454977&action=enter
Comment 7 Jan Safranek 2008-07-23 06:09:48 EDT
Created attachment 312454 [details]
changelog
Comment 8 Jan Safranek 2008-07-23 06:10:25 EDT
Created attachment 312455 [details]
SVN commit log
Comment 11 Alasdair 2008-11-02 18:21:40 EST
The net-snmp 5.3.2.2 release still suffers from a previously identified memory leak, patched in net-snmp 5.4.x.

Memory leak details available at http://sourceforge.net/tracker/index.php?func=detail&aid=1616912&group_id=12694&atid=456380

Can this patch be included in the build for RHEL 5.3 ?

Thanks
Alasdair
Comment 12 Alasdair 2008-11-02 18:35:23 EST
Requested this patch be applied in the next net-snmp-5.3.2.x update

https://sourceforge.net/tracker2/?func=detail&aid=2217367&group_id=12694&atid=112694
Comment 13 Jan Safranek 2008-11-03 03:01:00 EST
(In reply to comment #11)
> The net-snmp 5.3.2.2 release still suffers from a previously identified memory
> leak, patched in net-snmp 5.4.x.
> 
> Memory leak details available at
> http://sourceforge.net/tracker/index.php?func=detail&aid=1616912&group_id=12694&atid=456380

This leak was already found during our tests and will be fixed in RHEL 5.3.
Comment 15 Jan Safranek 2008-11-03 06:42:02 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
The Net-SNMP package has been rebased to the latest available bugfix release. No new features have been added with this release. The 5.3.x series is a bugfix only release tree since the release of Net-SNMP 5.4.0.
Comment 16 Don Domingo 2008-11-18 22:41:22 EST
this bug is now documented in the RHEL5.3 release notes. you can view a mock build of this document at the following link:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.3/html-single/Release_Notes/
Comment 17 Don Domingo 2008-11-18 22:41:22 EST
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1 +1,15 @@
-The Net-SNMP package has been rebased to the latest available bugfix release. No new features have been added with this release. The 5.3.x series is a bugfix only release tree since the release of Net-SNMP 5.4.0.+Net-SNMP has been re-based to upstream version 5.3.2.2. This update adds Stream Control Transmission Protocol (SCTP) support (as per RFC 3873, http://www.ietf.org/rfc/rfc3873.txt) and introduces two new configuration options (to be used in /etc/snmpd.conf):
+
+* 'dontLogTCPWrappersConnects' - suppresses logging of connection attempts.
+
+* 'v1trapaddress' - enables administrators to set an agent's IP address inside outgoing SNMP traps.
+
+This update also features several bug fixes from upstream, including:
+
+* The snmpd daemon now functions properly on systems with more than 255 network interfaces. In addition, snmpd also reports an error now when it is configured to listen on any port higher than 65535.
+
+* A race condition that caused the snmpd daemon to leak file descriptors when reading from /proc is now fixed.
+
+* The snmpd daemon now correctly reports hrProcessorLoad object IDs (OID), even on multi-CPU hardware. Note, however, that it takes approximately one minute from daemon startup to calculate the value of the OID.
+
+* The net-snmp-devel package is now dependent on the lm_sensors-devel package.
Comment 20 errata-xmlrpc 2009-01-20 17:07:22 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0230.html

Note You need to log in before you can comment on or make changes to this bug.