Bug 455026 - RFE: include RFC4876 schema
RFE: include RFC4876 schema
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.1.1
All Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks: 249650 FDS1.1.4 FDS1.2.0
  Show dependency treegraph
 
Reported: 2008-07-11 10:51 EDT by Nalin Dahyabhai
Modified: 2015-01-04 18:33 EST (History)
3 users (show)

See Also:
Fixed In Version: 8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 19:04:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example schema file (5.22 KB, text/plain)
2008-07-11 10:51 EDT, Nalin Dahyabhai
no flags Details
diffs (3.23 KB, patch)
2008-10-09 21:22 EDT, Rich Megginson
no flags Details | Diff
cvs commit log (5.33 KB, text/plain)
2008-10-16 12:44 EDT, Rich Megginson
no flags Details

  None (edit)
Description Nalin Dahyabhai 2008-07-11 10:51:03 EDT
Non-Linux clients tend to look for RFC4876-style DUAConfigProfile entries to
pull up information about how to access a directory.  It'd be handy if the
necessary attribute type and object class definitions were provided.
Comment 1 Nalin Dahyabhai 2008-07-11 10:51:03 EDT
Created attachment 311588 [details]
example schema file
Comment 2 Rich Megginson 2008-10-09 21:22:19 EDT
Created attachment 319966 [details]
diffs
Comment 3 Rich Megginson 2008-10-16 12:44:57 EDT
Created attachment 320576 [details]
cvs commit log

Reviewed by: nkinder (Thanks!)
Fix Description: Pieter D.J. Krul has contributed many schema files that
have been tested in production environments.  They are divided into two
groups - those that conflict with existing schema in DS, CertSys, and
IPA, and those which do not.  The latter are installed in the default
schema directory to be available for new instances - the former are
installed in the data directory just as the rfc2307bis schema.  The
schema provided cover autofs and rfc4876, as in the bug reports, and
more.  Here is the full list of new files:
60trust.ldif 60pureftpd.ldif 60sudo.ldif 60nis.ldif 60samba.ldif
60mozilla.ldif
60samba3.ldif 60krb5kdc.ldif 60sabayon.ldif 60kerberos.ldif
60rfc4876.ldif 60inetmail.ldif 60rfc3712.ldif 60eduperson.ldif
60rfc2739.ldif 60changelog.ldif 60radius.ldif 60autofs.ldif 60qmail.ldif
Platforms tested: RHEL5
Flag Day: no
Doc impact: yes - document the new schema
Comment 4 Jenny Galipeau 2009-04-08 12:47:11 EDT
verified DS 8.1 - 

HP-UX:

bash-3.00# ls /opt/dirsrv/share/data/60rfc4876.ldif 
/opt/dirsrv/share/data/60rfc4876.ldif


RHEL 4:

[root@jennyv4 data]# ls -al /usr/share/dirsrv/data/60rfc4876.ldif 
-rw-r--r--  1 root root 6181 Apr  1 19:58 /usr/share/dirsrv/data/60rfc4876.ldif
Comment 5 Chandrasekar Kannan 2009-04-29 19:04:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0455.html

Note You need to log in before you can comment on or make changes to this bug.