Bug 455119 - Dependency tokens must begin with alpha-numeric, '_' or '/'
Dependency tokens must begin with alpha-numeric, '_' or '/'
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-07-12 05:22 EDT by Nicolas Mailhot
Modified: 2009-04-14 11:57 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.6.0-2.fc10
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-21 06:23:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-07-12 05:22:15 EDT
FESCO decided to relegate UTF-8 from package names (where they work fine) to
synthetic Provides.

rpmbuild needs to be fixed to implement FESCO decision

$ rpmbuild -bs /tmp/ecolier-court-fonts.spec 
error: line 23: Dependency tokens must begin with alpha-numeric, '_' or '/':
Provides: écolier-court-fonts = 20070702-1.fc10.nim

Version-Release number of selected component (if applicable):

rpm-build-4.4.2.3-2.fc9.x86_64
Comment 1 Christopher D. Stover 2008-10-25 13:21:12 EDT
I didn't see this problem specifically addressed in the change log but is this problem fixed in rpm-4.6.0-0.rc1.5?
Comment 2 Jeff Johnson 2008-10-25 21:55:14 EDT
Its trivial to test whether the problem is fixed.

Install any *.src.rpm (I usually use the time pkg as a Guinea pig)

Add
    Provides: foo_with_utf8_chars

Build.

If the build fails, the problem has not been addressed.
Comment 3 Christopher D. Stover 2008-10-25 23:19:11 EDT
Thanks for bringing it down to my level Jeff. :D  It's definitely still a problem.  Adding the FutureFeature keyword since it's not a bug but this probably needs to be addressed in the near future.
Comment 4 Panu Matilainen 2009-02-21 06:23:56 EST
> rpmbuild needs to be fixed to implement FESCO decision

Let's get one thing straight here: FESCo does not get to dictate what rpm implements.

That aside, fixed in rawhide now.
Comment 5 Fedora Update System 2009-03-12 02:11:48 EDT
rpm-4.6.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpm-4.6.0-2.fc10
Comment 6 Fedora Update System 2009-04-14 11:57:15 EDT
rpm-4.6.0-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.