Bug 455147 - libgcrypt needs at least version 1.5 of libgpg-error
libgcrypt needs at least version 1.5 of libgpg-error
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgcrypt (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-12 15:54 EDT by Noa Resare
Modified: 2008-07-14 12:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 12:01:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noa Resare 2008-07-12 15:54:26 EDT
Description of problem:
The symbol gpg_err_code_from_syserror showed up between 1.4 and 1.5 of libgpg-error according to 
the ChangeLog. A small improvement to the libcrypt package would be to add this dependency 
explicitly to the package.

Version-Release number of selected component (if applicable):
1.4.0-3

How reproducible:
always

Steps to Reproduce:
1. try to recompile libgcrypt on for example rhel4
2.
3.
  
Actual results:
compilation fails with missing symbol gpg_err_code_from_syserror

Expected results:


Additional info:
Comment 1 Nalin Dahyabhai 2008-07-14 12:01:41 EDT
Despite the changelog, the function appears to have landed in time for 1.4, as
it's in the F7 package's source tree.  It looks like the requirement on >=1.4 is
correct, so I'm marking this won't-fix.  Please reopen this bug report if I've
missed something.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.