Bug 455164 - Review-Request: NaturalDocs - Documentation generator for multiple programming languages
Review-Request: NaturalDocs - Documentation generator for multiple programmin...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
http://netbsd.sk/~lkundrak/SPECS/Natu...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-13 06:21 EDT by Lubomir Rintel
Modified: 2008-12-28 16:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-28 16:42:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2008-07-13 06:21:35 EDT
SRPM: http://netbsd.sk/~lkundrak/SRPMS/NaturalDocs-1.4-2.el5.src.rpm
SPEC: http://netbsd.sk/~lkundrak/SPECS/NaturalDocs.spec

Description:

Natural Docs is an open-source documentation generator for multiple
programming languages.  You document your code in a natural syntax that
reads like plain English.  Natural Docs then scans your code and builds
high-quality HTML documentation from it.
Comment 1 Kevin Fenzi 2008-12-26 19:56:35 EST
I'll go ahead and review this... look for a full review soon.
Comment 2 Kevin Fenzi 2008-12-27 15:18:37 EST
OK - Package meets naming and packaging guidelines
OK - Spec file matches base package name. 
OK - Spec has consistant macro usage. 
OK - Meets Packaging Guidelines. 
OK - License (GPLv2+)
OK - License field in spec matches
OK - License file included in package
OK - Spec in American English
OK - Spec is legible.
OK - Sources match upstream md5sum:
05a9a2a392bd3d6d44d1576e624ba74a  NaturalDocs-1.4.zip
05a9a2a392bd3d6d44d1576e624ba74a  NaturalDocs-1.4.zip.orig

OK - BuildRequires correct
OK - Package has %defattr and permissions on files is good. 
OK - Package has a correct %clean section. 
OK - Package has correct buildroot
OK - Package is code or permissible content. 
OK - Packages %doc files don't affect runtime. 
OK - Package has rm -rf RPM_BUILD_ROOT at top of %install

OK - Package compiles and builds on at least one arch. 
OK - Package has no duplicate files in %files. 
OK - Package doesn't own any directories other packages own. 
OK - Package owns all the directories it creates. 
OK - No rpmlint output. 
OK - final provides and requires are sane.

SHOULD Items:

OK - Should build in mock. 
OK - Should build on all supported archs
OK - Should have dist tag
OK - Should package latest version

Issues: 

1. It looks pretty clear that the package is GPLv2+, but some of the files just say 
"the GPL". You might ping upstream about that and suggest they mention that it's v2 or
later. 

2. Might use 'install -p' to preserve the timestamp on the script. 

3. SourceUrl is not right... looks like they use naturaldocs instead of NaturalDocs
in there. 
Ie: 

http://downloads.sourceforge.net/naturaldocs/%{name}-%{version}.zip

None of those are blockers, so this package is APPROVED, provided you 
fix those up on import.
Comment 3 Lubomir Rintel 2008-12-27 17:46:34 EST
> Issues: 
> 
> 1. It looks pretty clear that the package is GPLv2+, but some of the files just
> say 
> "the GPL". You might ping upstream about that and suggest they mention that
> it's v2 or
> later. 
>
> 2. Might use 'install -p' to preserve the timestamp on the script. 
> 
> 3. SourceUrl is not right... looks like they use naturaldocs instead of
> NaturalDocs
> in there. 
> Ie: 
> 
> http://downloads.sourceforge.net/naturaldocs/%{name}-%{version}.zip
> 
> None of those are blockers, so this package is APPROVED, provided you 
> fix those up on import.

All three are reasonable and I will surely address them. Thanks for the review!

New Package CVS Request
=======================
Package Name: NaturalDocs
Short Description: Documentation generator for multiple programming languages
Owners: lkundrak
Branches: F-9 F-10 EL-5
Comment 4 Kevin Fenzi 2008-12-28 14:16:46 EST
cvs done.
Comment 5 Lubomir Rintel 2008-12-28 16:42:16 EST
Imported and built. Thanks Kevin!

Note You need to log in before you can comment on or make changes to this bug.