Bug 455281 - kmod-xenpv will not compile from SRPM
kmod-xenpv will not compile from SRPM
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xenpv-kmod (Show other bugs)
3.9
All Linux
low Severity medium
: ---
: ---
Assigned To: Don Dutile
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-14 12:49 EDT by Rich Graves
Modified: 2008-09-29 16:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 16:15:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Graves 2008-07-14 12:49:00 EDT
Description of problem:

1. Latest up2date-provided kmod-xenpv seems not entirely happy with current
security update 2.4.21-57.
2. Recompiling from SRPM with rpmbuild fails. Trivial patch to fix the problem
provided below.

Version-Release number of selected component (if applicable):

kmod-xenpv-0.1-9.el3 and xenpv-0.1-9.el3.src.rpm

How reproducible:

Always

Steps to Reproduce:
1. up2date --get-source kmod-xenpv
2. rpm -i /var/spool/up2date/xenpv-0.1-9.el3.src.rpm
3. Edit /usr/src/redhat/SPECS/xenpv.spec to %define kverrel 2.4.21-57.EL
4. rpmbuild -bb --target x86_64 /usr/src/redhat/SPECS/xenpv.spec
 
Actual results:

Hangs forever at "make oldconfig"

Expected results:

Compiles to binary RPMs.

Additional info:

Source of problem is that "make menuconfig" is asking what to do about kernel
components not mentioned in .config. User does not see the prompts because
output is redirected to /dev/null. Suggested fix is either to ensure that
.config is complete, or pipe in yes '' to accept all defaults.

--- SPECS/xenpv.spec.orig    2008-07-14 16:38:09.000000000 -0500
+++ SPECS/xenpv.spec       2008-07-14 16:37:59.000000000 -0500
@@ -148,7 +148,7 @@
        make mrproper > /dev/null
        # copy appropriate config file to seed make oldconfig
        cp -v configs/kernel-%{kverbase}-%{_target_cpu}${flavor:+-$flavor}.confi
g ./.config
-       make oldconfig > /dev/null
+       yes '' | make oldconfig > /dev/null
        # now, make dep; generates a ton of warnings so output error to /dev/nul
l as well
        make dep >& /dev/null
        # finally, onto building xenpv modules
Comment 2 Don Dutile 2008-07-22 15:54:35 EDT
Could you provide the output from 'uname -a' and a listing of your
/boot/grub/grub.conf file, and the output from "rpm -qa | grep kernel' ?

thanks... Don
Comment 3 Don Dutile 2008-07-22 16:02:30 EDT
I've tried the above build command on a 2.4.21-47, -50, and -57 kernel.
All worked.

Note: that I am running an ia32 kernel on an intel box.
      x86_64 kernel is for a 64-bit AMD box.

Q: is the failure occuring when trying to do a 64-bit kernel build on 
   an i386 system ?

- Don
Comment 4 Don Dutile 2008-09-29 16:15:48 EDT
As comment #3 states, I don't have this problem on two diff.
revs of rhel3 kernel.

Also, I've sent email to reporter for an update &/or verification,
and haven't gotten any response.

So closing for now as worksforme.  Reopen if still having problems.

Note You need to log in before you can comment on or make changes to this bug.