Bug 455290 - FEAT: results.xml should use a stylesheet
FEAT: results.xml should use a stylesheet
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-14 13:43 EDT by Greg Nichols
Modified: 2009-01-27 17:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 17:58:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot-Mozilla-Firefox.png (336.27 KB, image/png)
2009-01-14 20:36 EST, Yan Tian
no flags Details

  None (edit)
Description Greg Nichols 2008-07-14 13:43:44 EDT
Description of problem:

The results.xml should use a stylesheet to allow direct rendering when viewing
with a browser.
Comment 1 Greg Nichols 2008-08-19 14:11:15 EDT
Added to R19.
Comment 2 Greg Nichols 2008-08-27 21:41:56 EDT
Delayed to HTS 5.3
Comment 5 Yan Tian 2009-01-14 04:55:44 EST
In hts-5.3-12, the results.xml rendering failed when viewing with firefox. Re-assigned this bug.
Comment 6 Greg Nichols 2009-01-14 10:19:41 EST
Please describe the failure.   What URL was used, and what was the result?
Comment 7 Yan Tian 2009-01-14 20:36:46 EST
Created attachment 329057 [details]
Screenshot-Mozilla-Firefox.png

(In reply to comment #6)
> Please describe the failure.   What URL was used, and what was the result?

I opened the result.xml file from result package, but it was not readable. Please view the Screenshot-Mozilla-Firefox.png.
Comment 8 Greg Nichols 2009-01-15 12:49:22 EST
Since the stylesheet is a separate document at a relative URL, it won't be found when viewing results.xml from the results package via a "file:" URL.   This feature is only relevent to viewing results.xml on the SUT via an http: URL.

Closing this as NOTABUG.
Comment 9 Greg Nichols 2009-01-15 12:50:37 EST
On second thought - re-opening to move to MODIFIED.  Please verify the feature via a URL of the form http:<hostname>/hts/results.xml.
Comment 10 Yan Tian 2009-01-15 20:06:16 EST
Verified result.xml rendering ok with via http:URL in hts-5.3-12.
Comment 12 errata-xmlrpc 2009-01-27 17:58:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0047.html

Note You need to log in before you can comment on or make changes to this bug.