Bug 455291 - Supertuxkart crash after sometimes minutes
Supertuxkart crash after sometimes minutes
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: supertuxkart (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-14 13:56 EDT by Couret Charles-Antoine
Modified: 2009-02-18 16:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 13:24:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Couret Charles-Antoine 2008-07-14 13:56:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:


Version-Release number of selected component (if applicable):
supertuxkart-0.4-1

How reproducible:
Always


Steps to Reproduce:
1. Launch Supertuxkart
2. To play with this game
3. To do 2-3 races

Actual Results:
Supertuxkart crash currently a race.

Expected Results:


Additional info:
I use Fedora 9 x84_64 with the latest driver to nVidia (Geforce 8800 GTS). The game isn't fullscreen.
Comment 1 Hans de Goede 2008-07-14 14:17:54 EDT
Can you do the following (as root in a terminal):
yum install yum-utils
debuginfo-install supertuxkart

And then as normal user from a terminal:
gdb supertuxkart

This will give you a gdb prompt:
(gdb)

Type "run" here and start playing, once supertuxkart crashes type (bt) and paste
the full output here please.

Thanks!
Comment 2 Couret Charles-Antoine 2008-07-17 11:15:21 EDT
But, I have one error with this instruction.
http://forums.fedora-fr.org/viewtopic.php?id=34047

And, I don't find the correction, I am blocked...
Have you a suggestion ?
Comment 3 Hans de Goede 2008-07-17 11:30:41 EDT
Try entering the following command on the console (while already root) before
doing the debuginfo-install:
"export LANG=en_US.utf8"

Maybe that will fix it, you can also try updating yum:
"yum update yum"
Comment 4 Couret Charles-Antoine 2008-07-17 12:00:32 EDT
The error is :

"17:54:11 <3 998> [couretca@CHAMBRECAC ~]$ gdb supertuxkart
GNU gdb Fedora (6.8-11.fc9)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...

(gdb)
(gdb) run
Starting program: /usr/bin/supertuxkart
[Thread debugging using libthread_db enabled]
Data files will be fetched from: '/usr/share/supertuxkart/'
[New Thread 0x7f0262d8c740 (LWP 25743)]
[New Thread 0x12f8950 (LWP 25746)]
[Thread 0x12f8950 (LWP 25746) exited]
[New Thread 0x12f8950 (LWP 25747)]
[New Thread 0x4e5e950 (LWP 25748)]
Highscores will be saved in '/home/couretca/.supertuxkart/highscore.data'.
Error messages and other text output will be logged to
/home/couretca/.supertuxkart/stderr.log and stdout.log
[New Thread 0x1cf9950 (LWP 25749)]

Program received signal SIGABRT, Aborted.
0x0000003e08632215 in raise (sig=<value optimized out>) at
../nptl/sysdeps/unix/sysv/linux/raise.c:64
64        return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
Current language:  auto; currently c
Missing separate debuginfos, use: debuginfo-install alsa-lib.x86_64
audiofile.x86_64 esound.x86_64 libX11.x86_64 libXau.x86_64 libXcursor.x86_64
libXdmcp.x86_64 libXext.x86_64 libXfixes.x86_64 libXrandr.x86_64
libXrender.x86_64 libXxf86vm.x86_64 libogg.x86_64 libxcb.x86_64"

	
I can't go further
Comment 5 Hans de Goede 2008-07-17 13:03:50 EDT
The missing seperate debuginfo's really isn't a problem, its more of a warning,
you should still get a "(gdb)" prompt after that, please do it again and type
"bt" after the (gdb) prompt, and paste the output it gives then.
Comment 6 Couret Charles-Antoine 2008-07-18 21:33:25 EDT
Oh, I am sorry

The complete error is :

03:27:04 <1 998> [couretca@CHAMBRECAC ~]$ gdb supertuxkart
GNU gdb Fedora (6.8-11.fc9)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
(gdb) run
Starting program: /usr/bin/supertuxkart
[Thread debugging using libthread_db enabled]
Data files will be fetched from: '/usr/share/supertuxkart/'
[New Thread 0x7f81c72b1740 (LWP 21059)]
[New Thread 0x12f8950 (LWP 21062)]
[Thread 0x12f8950 (LWP 21062) exited]
[New Thread 0x12f8950 (LWP 21063)]
[New Thread 0x47fc950 (LWP 21064)]
Highscores will be saved in '/home/couretca/.supertuxkart/highscore.data'.
Error messages and other text output will be logged to
/home/couretca/.supertuxkart/stderr.log and stdout.log
[New Thread 0x7ced950 (LWP 21065)]

Program received signal SIGABRT, Aborted.
0x0000003e08632215 in raise (sig=<value optimized out>) at
../nptl/sysdeps/unix/sysv/linux/raise.c:64
64        return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
Current language:  auto; currently c
Missing separate debuginfos, use: debuginfo-install alsa-lib.x86_64
audiofile.x86_64 esound.x86_64 libX11.x86_64 libXau.x86_64 libXcursor.x86_64
libXdmcp.x86_64 libXext.x86_64 libXfixes.x86_64 libXrandr.x86_64
libXrender.x86_64 libXxf86vm.x86_64 libogg.x86_64 libxcb.x86_64
(gdb) bt
#0  0x0000003e08632215 in raise (sig=<value optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x0000003e08633d83 in abort () at abort.c:88
#2  0x0000003e0862b039 in __assert_fail (assertion=<value optimized out>,
    file=<value optimized out>, line=<value optimized out>, function=<value
optimized out>)
    at assert.c:78
#3  0x00000000004703d8 in DefaultRobot::calc_steps (this=<value optimized out>)
    at robots/default_robot.cpp:789
#4  0x0000000000471cf8 in DefaultRobot::update (this=0x7f81bc62f620,
delta=0.00200000009)
    at robots/default_robot.cpp:100
#5  0x0000000000438674 in World::update (this=0x7f81bfb0b850, dt=0.00200000009)
at world.cpp:307
#6  0x00000000004435a0 in GameManager::run (this=0x2811c30) at game_manager.cpp:90
Comment 7 Hans de Goede 2008-07-19 01:53:37 EDT
Thanks! Thats just the info I need, it may take a few days before I can find the
time to look into this, but I think there is a good chance I can fix this given
this info!
Comment 8 Gwyn Ciesla 2008-09-10 10:19:51 EDT
High, new supertuxkart maintainer.  

Three questions.  One, does this still happen to you, and after how long, and on which track?

Two, can I have the stderr.log and stdout.log files from ~./supertuxkart?

Three, is this the stock Fedora nvidia driver or the proprietary driver directly from nvidia?

Thanks!
Comment 9 Couret Charles-Antoine 2008-09-10 11:13:07 EDT
1-I don't understand the first question. This bug happen few minutes after start the game, between 2-4 races. 

2-stderr.log

WARNING: sgMat4ToCoord: ERROR - Bad Matrix.

stdout.log is empty.

3-The proprietary driver from nVidia (via Livna).
Comment 10 Gwyn Ciesla 2008-09-10 11:32:49 EDT
1- I was just wondering if the game was still crashing for you.

3- Is the game playable if you use a different driver, such as the included nv driver, or the vesa driver, and if so, does it crash then?
Comment 11 Gwyn Ciesla 2008-09-15 14:06:31 EDT
Also, does the version in rawhide work for you?  You can get it here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=62154

If it does, I'll simply build that version for F-9.
Comment 12 Gwyn Ciesla 2008-12-31 11:37:15 EST
Ping?
Comment 13 Gwyn Ciesla 2009-02-18 13:24:09 EST
Still can't reproduce this, and no response from reporter.  If this is still a problem without the proprietary driver, please repoen.
Comment 14 Couret Charles-Antoine 2009-02-18 16:37:48 EST
Oh, sorry ! I don't read the email of Bugzilla...
This bug is solved...

Note You need to log in before you can comment on or make changes to this bug.