Bug 455307 - "/sbin/ldconfig: /lib/ld-linux.so.2 is not a symbolic link" when installing kernel
"/sbin/ldconfig: /lib/ld-linux.so.2 is not a symbolic link" when installing k...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-07-14 15:12 EDT by Quentin Armitage
Modified: 2008-10-29 13:36 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 13:36:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/tmp/rpm-tmp.59649 file created by yum install kernel-devel (298 bytes, text/plain)
2008-07-14 16:06 EDT, Quentin Armitage
no flags Details

  None (edit)
Description Quentin Armitage 2008-07-14 15:12:20 EDT
Description of problem:
I get the following errors on installation of kernel and kernel-devel 2.6.26-
136.f10
For kernel:
/sbin/ldconfig: /lib/ld-linux.so.2 is not a symbolic link

For kernel-devel:
/var/tmp/rpm-tmp.92170: line 12:  : command not found
error: %post(kernel-devel-2.6.26-136.fc10.i686) scriptlet failed, exit status 
127

Version-Release number of selected component (if applicable):
kernel-2.6.26-136.fc10

How reproducible:
Always

Steps to Reproduce:
1.yum install kernel kernel-devel
2.
3.
  
Actual results:
Error messages given above

Expected results:
No error messages

Additional info:
Up to and including kernel-2.6.26-0.131.fc9.git9.fc10 I didn't get the error 
messages.

BTW, should fedora_cvs_origin have been set to 760 for the 2.6.26 released 
kernel?
Comment 1 Dave Jones 2008-07-14 15:29:10 EDT
two separate bugs here.

/sbin/ldconfig: /lib/ld-linux.so.2 is not a symbolic link

is a mkinitrd bug.  (reassigned).


The other..
For kernel-devel:
/var/tmp/rpm-tmp.92170: line 12:  : command not found
error: %post(kernel-devel-2.6.26-136.fc10.i686) scriptlet failed, exit status 

is a mystery.
Can you cat /var/tmp/rpm-tmp.92170 and find out what command its barfing on?
Comment 2 Quentin Armitage 2008-07-14 16:06:09 EDT
Created attachment 311766 [details]
/var/tmp/rpm-tmp.59649 file created by yum install kernel-devel
Comment 3 Quentin Armitage 2008-07-14 16:07:03 EDT
I attach a new /var/tmp/rpm-tmp.nnnnn from a re-install. It is not easy to catch
since it only exists for a few milli-seconds.

There appears to be a stray \x19 (^Y) character at end of the file (line 12)
Comment 4 Dave Jones 2008-07-14 16:19:07 EDT
That looks like an rpm bug.  I recommend leaving this one for Peter to take care
of mkinitrd, and file a seperate one for the rpm bug.
Comment 5 Quentin Armitage 2008-07-14 16:39:07 EDT
rpm bug filed as 455333
Comment 6 Panu Matilainen 2008-07-15 13:56:04 EDT
Just FYI, the junk at end of script was a bug in rpm macro argument handling (a
build, not runtime issue) which should be fixed now in rpm-4.5.90-0.git8426.8
which just finished building.

The kernel spec is pretty heavy on macros making it a likely candidate for
catching regressions in that area...
Comment 7 Christopher D. Stover 2008-10-26 22:33:23 EDT
Has this still been an issues Quentin or can we close this as fixed in rawhide?
Comment 8 Tom "spot" Callaway 2008-10-29 13:36:08 EDT
Closing this as fixed, since I can no longer reproduce this. If it is not fixed in the Preview release, please reopen.

Note You need to log in before you can comment on or make changes to this bug.