Bug 455326 - Feature Request: timeout on start/stop actions
Feature Request: timeout on start/stop actions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-14 16:15 EDT by Ryan O'Hara
Modified: 2010-10-22 22:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:57:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Pass 2 - includes patch from Ryan O'Hara (4.11 KB, patch)
2008-09-02 14:57 EDT, Lon Hohberger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0101 normal SHIPPED_LIVE rgmanager bug-fix and enhancements update 2009-01-20 11:04:34 EST

  None (edit)
Comment 2 Lon Hohberger 2008-07-15 13:36:21 EDT
Ryan, a hint on implementation --

 * Every resource action has a timeout value; it's just not used
 * you'll probably be implementing this 'timeout' checking within the context of
the res_exec function (src/daemons/restree.c)
 * I would not recommend making 'enforced timeouts' the default method of
operation because it could break existing behavior.  As such, you will want to
think about whether you think this should be a per-resource thing (think:
__independent_subtree), a per-service thing (e.g. failover domains), or a global
thing (probably not, but maybe).

Comment 5 Lon Hohberger 2008-09-02 14:57:38 EDT
Created attachment 315578 [details]
Pass 2 - includes patch from Ryan O'Hara
Comment 6 Ryan O'Hara 2008-09-08 13:54:36 EDT
Looks good.
Comment 10 errata-xmlrpc 2009-01-20 15:57:17 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0101.html

Note You need to log in before you can comment on or make changes to this bug.