Bug 455405 - Installing on more than une USB key (pendrives) fails with FileSystem errors
Installing on more than une USB key (pendrives) fails with FileSystem errors
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-15 08:43 EDT by Giacomo Montagner
Modified: 2008-07-22 03:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 03:42:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg with EXT3 errors (74.77 KB, text/plain)
2008-07-19 13:39 EDT, Giacomo Montagner
no flags Details

  None (edit)
Description Giacomo Montagner 2008-07-15 08:43:38 EDT
Description of problem:
Hi, 
I'm trying to install Fedora 9 (I also tried with a CentOS 5.1, with same
result) on 2 usb pendrives to build a fanless/silent system to use it as a home
server (print server, DNS, dhcp, firewall/gateway, ecc. for my LAN). 
To improve performances, since usb keys are usually slow, I tried to build a
RAID0 over the 2 usb drives. This leads to filesystem unrecoverable errors on
the first boot after installation (note that installation went good). 

This is the partitioning scheme: 
/dev/sda (first usb drive, 4GB):
/dev/sda1    /boot     ext3    128MB
/dev/sda2    Linux Raid Autodetect    first half of /dev/md0   (remaining space)

/dev/sdb (second usb drive, 4GB, identical to the previous):
/dev/sdb1    swap    128MB 
/dev/sdb2    Linux Raid Autodetect   second half of /dev/md0   (remaining space)

the two partitions /dev/sda2 and /dev/sdb2 are identical. /dev/md0 is used as /
partition. 

After the reboot RAID0 was auto-detected but fsck found fatal errors on
filesystem, and stopped asking for root password for maintenance. 

After a pair of failures I tried with LVM, creating 2 physical volumes on
/dev/sda2 anda /dev/sdb2, assigning them to 1 volume group, then creating one
striped volume over that and using it as / partition (I did this partially by
command line during installation, using lvm command). 

This time the installation didn't even get to the end, and on one of the
consoles I found ext3 filesystem errors. 

As a last chance I tried with a different partitioning scheme: 

/dev/sda1    /boot   ext3   128MB
/dev/sda2    swap           128MB
/dev/sda3    /       ext3   (remaining space)

/dev/sdb1    /usr    ext3   (all drive)

this, too, failed (sigh!): the installation went apparently good but after boot,
immediately after udev start (which said [ OK ]) I got a /sbin/telinit segfault
and boot stopped. 

I tried to install fedora using my laptop and the server I'm trying to setup,
both of them gave the same results. 

Today I tested the 2 usb keys for read/write but they seem to work good (I made
a test file of the precise size of the keys, sha1sum'ed it, wrote it to the keys
and sha1sum'ed the keys, after removing and re-attaching them, and the sums are
the same). 

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Get a computer which supports boot from usb
2. insert fedora 9 netinstall cd
3. perform an installation using one of the partitioning schemes listed above
4. reboot after installation when asked

  
Actual results:
Unrecoverable filesystem corruptions and/or init segfaults

Expected results:
Full-functional installation

Additional info:
As server I'm using a pc made only of: 
- an Intel D201GLY2 motherboard, all system components are onboard
- 1GB DDR2 Ram 
- an Asus CD-ROM reader
- 2 usb keys of 4GB size
The same filesystem corruption was observed when I performed the same RAID0
configuration using my laptop and the same 2 usb drives (so I excluded the
failure might be caused by any hardware component, since the 2 usb drives are
the only things in common between the 2 setups, and I tested them). 

I also tried to perform a plain install over a 2GB usb drive using a single
partition over the whole device, and that seems to work perfectly. Next I'm
trying to do the same over one (or both, maybe) of the 4GB usb drives, just to
complete the scenario.
Comment 1 Giacomo Montagner 2008-07-19 13:39:17 EDT
Created attachment 312206 [details]
dmesg with EXT3 errors
Comment 2 Giacomo Montagner 2008-07-19 13:45:29 EDT
Hi, 
I installed a virtual machine and then copied files onto the usb keys, recreated
the initrd and was able to boot into the system twice without problems. 
I used the first, raid0, layout. 
Then I created a file as big as (almost) the free space on /, rebooted and again
it went good. Finally, I tried to remove the big file and got the errors you can
find in the attachment above (dmesg from the running system). 

I googled around a bit - it seems this bug is well-known but i didn't quite find
a resolution. Now I'm going to test the drives against _removal_ of files,
trying to find wether it's a faulty hardware or a software problem. 
I found this bug: https://bugzilla.redhat.com/show_bug.cgi?id=442106
which is quite recent and maybe related to this. 

Bye. 
Comment 3 Giacomo Montagner 2008-07-22 03:42:14 EDT
I finally managed to reproduce the problem over only one of the 2 usb drives, it
apperas as a hardware problem. 
While writing/reading files over the usb drive there seem to be no problems, but
when removing files one of the usb keys give filesystem problems, the other not. 

Bye. 

Note You need to log in before you can comment on or make changes to this bug.