Bug 45550 - compile fails at binfmt_xout.c
compile fails at binfmt_xout.c
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-22 16:00 EDT by Markku Kolkka
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-22 16:03:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script of the compilation session (705.78 KB, text/plain)
2001-06-22 16:03 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2001-06-22 16:00:36 EDT
Description of Problem:
Recompilation of kernel 2.4.5-0.4 with standard Athlon configuration 
fails because of missing include files in binfmt_xout.c

How Reproducible:
Always

Steps to Reproduce:
1. Install kernel-source-2.4.5-0.4
2. make mrproper
3. cp configs/kernel-2.4.5-athlon.config .config
4. make oldconfig
5. make dep clean bzImage modules

Actual Results:
(In make modules:)
gcc -D__KERNEL__ -I/usr/src/linux-2.4.5/include -Wall -Wstrict-prototypes 
-O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused 
-pipe -mpreferred-stack-boundary=2 -march=athlon  -DMODULE -DMODVERSIONS 
-include /usr/src/linux-2.4.5/include/linux/modversions.h   -c -o 
binfmt_xout.o binfmt_xout.c
binfmt_xout.c:34:21: abi/abi.h: No such file or directory
binfmt_xout.c:35:22: abi/xout.h: No such file or directory
(more errors and warnings...)

Expected Results:


Additional Information:
RH 7.1, gcc-2.96-88
Comment 1 Markku Kolkka 2001-06-22 16:03:02 EDT
Created attachment 21585 [details]
script of the compilation session
Comment 2 Arjan van de Ven 2001-06-22 16:07:45 EDT
thanks for reporting.
This was a packaging bug, I fixed it now; should appear in rawhide soon

Note You need to log in before you can comment on or make changes to this bug.