This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 455562 - Could not start Gnome, Kde or failsafe from KDM window
Could not start Gnome, Kde or failsafe from KDM window
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-16 04:10 EDT by BeGe
Modified: 2008-07-16 09:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.0.98-7.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-16 09:28:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kdm.log from a live image (2.38 KB, text/plain)
2008-07-16 05:42 EDT, Sebastian Vahl
no flags Details

  None (edit)
Description BeGe 2008-07-16 04:10:40 EDT
Description of problem: could not start Gnome or KDE from KDM login


Version-Release number of selected component (if applicable):
Latest update of rawhide from 15/07/2008
Kernel 2.6.26-138.fc10.i686
glibc-2.8.90-8.i686


How reproducible:
Boot linux up to KDM login windows
Choose whatever user including root and select Gnome, KDE or Failsafe
then i receive the linux login line prompt instead of starting the desktop manager


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Linux line prompt


Expected results:


Additional info:
looking at system messages with 'dmesg' command, after i tried to login with kdm
i got the following messages at the end of the dmesg log:

kdm[222]: segfault at 7665642f ip 00560e9b sp bf9408ac error 4 in
libc-2.8.90.so [4ea000+16d000]
and then
mtrr: no MTRR for f0000000,1000000 found

So i am quite sure that the problem is not in glibc but kdm is not a component
that i can choose in the list.
I do not think also that mtrr is the problem. 
Additional info: i am running rawhide on a vmware virtual machine so the video
is also virtualized.
Comment 1 Kevin Kofler 2008-07-16 04:27:50 EDT
What version of kdebase-workspace?
Comment 2 BeGe 2008-07-16 04:42:41 EDT
It is kdebase-workspace-4.0.98-5.fc10.i386 just installed above 4.0.98-3 that
was working.
Comment 3 BeGe 2008-07-16 05:00:17 EDT
To clarify 
4.0.98-3 was working
4.0.98-5 has the problem
Comment 4 Sebastian Vahl 2008-07-16 05:42:26 EDT
Created attachment 311934 [details]
kdm.log from a live image
Comment 5 Sebastian Vahl 2008-07-16 05:42:48 EDT
Same here for the live images. KDM seems to crash immediately after the 
booting process. I can only start it if I disable the automatic login. But it 
also crashes when I'm logging in the user then.

(I've attached a kdm.log above)
Comment 6 Rex Dieter 2008-07-16 08:08:10 EDT
I can confirm this now too.  I'm sorry, I thought I had confirmed a 
functioning kdm (apparently restarting X isn't enough to respawn a new kdm?).
Comment 7 Kevin Kofler 2008-07-16 08:22:05 EDT
Indeed, the ConsoleKit patch is screwed up, and I think I know already where. 
There is no way this could have worked. Rex, restarting X is not enough, you 
have to reboot to test a new KDM, or telinit 3 and telinit 5.
Comment 8 BeGe 2008-07-16 09:01:29 EDT
If you like you can decrease the priority of this issue as i have found a way to
start KDE from the linux command lines:
I prepared a .xinitrc file in my $HOME directory that starts some xterm and
gnome-tw. Then i entered xinit
Then I started KDE with "/bin/sh /usr/bin/startkde" in one of my xterm window
and everything starts correctly.
I think it is no more a major issue.
Comment 9 Kevin Kofler 2008-07-16 09:03:27 EDT
I think it's a very serious issue, and in any case we're already on it, I think 
I fixed it, crossing fingers...
Comment 10 Kevin Kofler 2008-07-16 09:28:38 EDT
Confirmed fixed.

Note You need to log in before you can comment on or make changes to this bug.