This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 455571 - GFS2: [RFE] fiemap support for GFS2
GFS2: [RFE] fiemap support for GFS2
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: GFS-kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Steve Whitehouse
: FutureFeature
Depends On: 242066 296951
Blocks: 476626
  Show dependency treegraph
 
Reported: 2008-07-16 06:38 EDT by Steve Whitehouse
Modified: 2009-01-06 03:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 03:26:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First guesstimated patch (2.60 KB, patch)
2008-10-06 09:46 EDT, Steve Whitehouse
no flags Details | Diff
Latest version of patch (5.40 KB, patch)
2008-10-14 10:01 EDT, Steve Whitehouse
no flags Details | Diff
My version of Eric's test program (6.16 KB, text/x-csrc)
2008-10-14 10:05 EDT, Steve Whitehouse
no flags Details

  None (edit)
Description Steve Whitehouse 2008-07-16 06:38:00 EDT
GFS2 should support fiemap directly.
Comment 1 Steve Whitehouse 2008-10-06 09:46:42 EDT
Created attachment 319557 [details]
First guesstimated patch

Based on the current proposed upstream patches. Not tested. Need to resolve locking order issue wrt the inode mutex. Currently this compiles, but is untested.
Comment 2 Steve Whitehouse 2008-10-14 10:01:33 EDT
Created attachment 320301 [details]
Latest version of patch

As posted for review by the powers that be.
Comment 3 Steve Whitehouse 2008-10-14 10:05:49 EDT
Created attachment 320303 [details]
My version of Eric's test program

I updated this from the version I found on the mailing lists so that it works with the latest FIEMAP impelmentation. Might need to copy some kernel headers to /usr/include/linux by hand as it looks like make headers_install doesn't do that.
Comment 4 Steve Whitehouse 2009-01-06 03:26:43 EST
This hit Linus' kernel today.

Note You need to log in before you can comment on or make changes to this bug.