Bug 45568 - grip crashes after a 2nd CDDB request
grip crashes after a 2nd CDDB request
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: grip (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-22 18:27 EDT by Laurent CREPET
Modified: 2014-03-16 22:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-06 00:17:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurent CREPET 2001-06-22 18:27:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
When grip takes a long time to retrieve CDDB data for unknown disks:
1. I cancel the CDDB request clicking on the specific button
2. I restart the CDDB request clicking again
=> grip crashes, sometimes with core.
=> seen on RH 7.0 and 7.1 (perhaps also 6.2)

3. I re-run grip, and then the audio CD is known, every track has a title,
etc.


How reproducible:
Always

Steps to Reproduce:
1. cancel the CDDB request clicking on the specific button
2. restart the CDDB request clicking again
3.
	

Actual Results:  grip crashes and sometimes with core.

Expected Results:  No crash !

Additional info:
Comment 1 Tim Powers 2001-06-27 09:49:37 EDT
You may want to try using the grip package located in
http://people.redhat.com/RPMS. It should work properly for you.

Please let me knopw if this does it for you or not.

Tim
Comment 2 Laurent CREPET 2001-06-27 10:01:12 EDT
> http://people.redhat.com/RPMS

that works better with http://people.redhat.com/timp/RPMS/
I'll check if your RPM fixes the problem.
Comment 3 Laurent CREPET 2001-06-27 14:35:29 EDT
I've just download and install
http://people.redhat.com/timp/RPMS/grip-2.95-2.i386.rpm
I still reproduce the problem by clicking 3 or 4 times on the CDDB request 
button.
No core but, the following message on the command-line:
[1]+  Real-time signal 0      grip
Comment 4 Bill Nottingham 2003-02-06 00:17:32 EST
Works for me ok with 3.0.5-x

Note You need to log in before you can comment on or make changes to this bug.