Bug 455709 - Eclipse generates an error on startup: java.lang.UnsatisfiedLinkError: memmove
Eclipse generates an error on startup: java.lang.UnsatisfiedLinkError: memmove
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
9
ia64 Linux
low Severity high
: ---
: ---
Assigned To: Doug Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-17 05:12 EDT by Mark Wickens
Modified: 2009-01-27 10:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-27 10:54:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Eclipse error log file: ~/workspace/.metadata/.log (2.28 KB, text/plain)
2008-07-17 05:12 EDT, Mark Wickens
no flags Details
Eclipse log file for my Fedora 10 installation (1.58 MB, text/plain)
2008-12-11 21:07 EST, Juan
no flags Details

  None (edit)
Description Mark Wickens 2008-07-17 05:12:49 EDT
Description of problem:

Eclipse displays an error box on startup: 
An error has occurred. See the log file /home/msw/workspace/.metadata/.log


Version-Release number of selected component (if applicable):
Fedora Eclipse 3.3.2, Eclipse build: M20080221-1800
Java Version 1.6.0

How reproducible:
Startup eclipse with command: $ eclipse
  
Actual results:
Eclipse fails to start

Expected results:
Eclipse should start

Additional info:
Comment 1 Mark Wickens 2008-07-17 05:12:49 EDT
Created attachment 312016 [details]
Eclipse error log file: ~/workspace/.metadata/.log
Comment 2 Mark Wickens 2008-07-17 05:16:52 EDT
Sorry, forgot to mention - all software wsa used from a straight install of
Fedora 9 - no monkey business involved :)
Comment 3 Mark Wickens 2008-07-17 05:24:41 EDT
$ for f in `rpm -aq | egrep "eclipse|swt"` do rpm -qV $f; done
Unsatisfied dependencies for eclipse-jdt-3.3.2-11.fc9.ia64: java-javadoc

$ readlink -f `which java`
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java

$ readlink -f `which javac`
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/bin/javac

$ java -version
java version "1.6.0"
OpenJDK  Runtime Environment (build 1.6.0-b09)
OpenJDK 64-Bit Core VM (build 1.6.0-b09, interpreted mode)
Comment 4 Andrew Overholt 2008-07-17 09:53:31 EDT
Doug:  can you investigate?
Comment 5 Juan 2008-12-11 21:05:15 EST
The same happens to me in Fedora 10.

I have last versions of all eclipse packages installed from Fedora repository:
eclipse-subclipse-book-1.2.4-12.fc10.noarch
eclipse-nls-zh-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-mylyn-webtasks-3.0.3-3.fc10.noarch
eclipse-mylyn-3.0.3-3.fc10.noarch
eclipse-nls-pt_BR-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-setools-3.3.2.4-3.fc10.i386
eclipse-rpm-editor-0.4.0-5.fc10.i386
eclipse-nls-it-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-el-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-cdt-mylyn-5.0.0-10.fc10.i386
eclipse-nls-zh_TW-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-quickrex-3.5.0-9.fc10.noarch
eclipse-egit-0.3.1.20081022-3.fc10.noarch
maven2-plugin-eclipse-2.0.4-10.15.fc10.i386
eclipse-cdt-5.0.0-10.fc10.i386
eclipse-pde-3.4.1-5.fc10.i386
eclipse-nls-ru-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-hu-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-checkstyle-4.0.1-11.fc10.i386
tomcat5-jasper-eclipse-5.5.27-6.1.fc10.noarch
eclipse-mylyn-pde-3.0.3-3.fc10.noarch
eclipse-pydev-mylyn-1.3.24-1.fc10.noarch
eclipse-slide-1.3.9-3.fc10.noarch
eclipse-nls-ja-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-tr-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-ecj-3.4.1-5.fc10.i386
eclipse-platform-3.4.1-5.fc10.i386
eclipse-nls-ko-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-no-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-da-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-epic-0.6.27-1.fc10.i386
icu4j-eclipse-3.8.1-4.fc10.i386
eclipse-nls-es-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-pt-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-uk-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-photran-4.0.0-0.b4.fc10.3.i386
eclipse-pydev-1.3.24-1.fc10.noarch
eclipse-nls-de-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-ro-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-gef-examples-3.4.1-1.fc10.i386
eclipse-mylyn-java-3.0.3-3.fc10.noarch
eclipse-nls-fr-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-gef-3.4.1-1.fc10.i386
eclipse-swt-3.4.1-5.fc10.i386
eclipse-nls-ar-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-pl-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-rcp-3.4.1-5.fc10.i386
eclipse-nls-fi-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-nls-sv-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-cdt-sdk-5.0.0-10.fc10.i386
eclipse-jdt-3.4.1-5.fc10.i386
eclipse-mylyn-trac-3.0.3-3.fc10.noarch
eclipse-nls-nl-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-photran-xlf-4.0.0-0.b4.fc10.3.i386
eclipse-nls-he-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-gef-sdk-3.4.1-1.fc10.i386
eclipse-nls-cs-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-phpeclipse-1.2.1-2.fc10.i386
eclipse-shelled-1.0.3-3.fc10.noarch
eclipse-subclipse-1.2.4-12.fc10.noarch
eclipse-nls-bg-0.2.0-0.5.20080807snap.fc10.noarch
eclipse-changelog-2.6.3-2.fc10.i386

I get the same message after a long wait, but in fact ~/workspace/.metadata/.log doesn't exist.
I attach ~/.eclipse/org.eclipse.platform_3.4.0_155965261/configuration/1229046645133.bak_0.log
Comment 6 Juan 2008-12-11 21:07:13 EST
Created attachment 326698 [details]
Eclipse log file for my Fedora 10 installation
Comment 7 Juan 2008-12-11 21:08:32 EST
Comment on attachment 326698 [details]
Eclipse log file for my Fedora 10 installation

See comment #5
Comment 8 Andrew Overholt 2008-12-11 21:28:42 EST
Juan:  did you actually get an UnsatisfiedLinkError on memmove?  Judging from your log it looks like you have a lot of issues with the translations being picked up.  Can you try running from a terminal with the -clean argument?

$ eclipse -clean -data /tmp/NewWorkspaceToTry

Can you also see if this command generates any output:

$ for f in `rpm -qa | grep eclipse`; do rpm -qV $f; done

Thanks.
Comment 9 Juan 2008-12-11 22:15:08 EST
No, I didn't get that error. I got the message "An error has occurred. See the log file /home/msw/workspace/.metadata/.log", but as that file doesn't in fact exist, it could happen that I just don't see the UnsatisfiedLinkError.

- This is the result of running with -clean argument:
$ /usr/bin/eclipse -clean -data /tmp/NowWorkspaceTotry
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
!SESSION 2008-12-12 03:51:21.191 -----------------------------------------------
eclipse.buildId=M20080911-1700
java.version=1.6.0_11
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=es_ES
Command-line arguments:  -os linux -ws gtk -arch x86 -clean -data /tmp/NowWorkspaceTotry

This is a continuation of log file /home/juan/.eclipse/org.eclipse.platform_3.4.0_155965261/configuration/1229050282487.bak_0.log
Created Time: 2008-12-12 04:09:09.839

As you can see, I'm using Sun jdk 1.6.0_11, but I also tried to remove the JAVA_HOME environment variable and corresponding PATH entries so that it used the default JDK and the same happenned. Do you need that I retry that from a terminal to see the output?

- The other command didn't generate any output.

Thanks a lot.
Comment 10 Andrew Overholt 2008-12-12 13:48:27 EST
This should really be filed as a new bug so please do that.

In the interest of moving things along, though, try temporarily moving ~/.eclipse out of the way.  Something like:

$ mv ~/.eclipse{,.debugging455709}
$ eclipse -data /tmp/YetAnotherNewWorkspace

If that doesn't work, put the output of the following into the new bug you're going to file:

$ eclipse -debug -consolelog -data /tmp/YANW2
Comment 11 Juan 2008-12-12 14:41:08 EST
I already tried to totally remove .eclipse and workspace and didn't work.
I'll post a new bug with the information you've suggested.
Thank you very much and sorry for posting in the wrong place,

Juan
Comment 12 Doug Chapman 2009-01-27 10:54:52 EST
We won't be able to do anything on this until Fedora gets built on ia64 again.  Closing but will re-open if we find this is still an issue once Fedora-ia64 builds begin again.

Note You need to log in before you can comment on or make changes to this bug.