Bug 455802 - named service crashes with an assertion failed message
named service crashes with an assertion failed message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bind (Show other bugs)
5.2
All Linux
low Severity high
: rc
: ---
Assigned To: Adam Tkac
:
Depends On:
Blocks: 462060
  Show dependency treegraph
 
Reported: 2008-07-17 17:07 EDT by Clayton Keller
Modified: 2014-04-14 23:29 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 03:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Keller 2008-07-17 17:07:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

Description of problem:
Since the upgrade to the following:

Version: 9.3.4
Release: 6.0.2.P1.el5_2

We have had an issue with the named service randomly dieing off. In /var/log/messages we see the following errors:

Jul 17 13:00:42 ns-mail named[19409]: socket.c:1649: INSIST(!sock->pending_recv) failed
Jul 17 13:00:42 ns-mail named[19409]: exiting (due to assertion failure)

The server is running bind-chroot and also has the caching-nameserver package installed. In addition to the local related zones, we also have 10 forwards setup in the named.conf file.

This occurred on a fresh install of 5.2 which had the named service running for approximately 36 hours prior to this crash.

Version-Release number of selected component (if applicable):
bind-9.3.4-6.0.2.P1.el5_2

How reproducible:
Sometimes


Steps to Reproduce:
1.This has been random thus far. 
2.A restart of the service is required as it crashes.
3.

Actual Results:


Expected Results:


Additional info:
A point to also note is that we had a 4.6 server running the latest security patched BIND and this same error occurred on it after the recent BIND related security patches. The named.conf was identical on the 4.6 server too. We then decided to migrate to 5.2, in which we have seen this same issue happen today, thus the bug report.
Comment 1 Adam Tkac 2008-09-12 07:15:29 EDT
This problem is already fixed in upstream:

2406.   [bug]           Sockets could be closed too early, leading to
                        inconsistent states in the socket module. [RT #18298]

Problem will probably fixed together with bug #457036 by rebase to updated upstream version.
Comment 4 Denise Dumas 2009-03-30 14:48:02 EDT
Although this should be fixed by the rebase to 9.3.6-P1, I am removing the rebase keyword on this BZ per sly, because that is already set on BZ 457036.
Comment 7 Petr Sklenar 2009-04-29 06:05:26 EDT
Yes we have to! its in our plans, bind is core and it will be there asap
Comment 8 Chris Ward 2009-07-03 14:04:52 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 11 errata-xmlrpc 2009-09-02 03:37:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1420.html

Note You need to log in before you can comment on or make changes to this bug.