Bug 455915 - gnome-python2-gtkmozembed needs to be rebuilt against new xulrunner
gnome-python2-gtkmozembed needs to be rebuilt against new xulrunner
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-python2-extras (Show other bugs)
9
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 455947 455956 (view as bug list)
Depends On: 455936
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-18 14:49 EDT by David Juran
Modified: 2008-07-23 03:04 EDT (History)
12 users (show)

See Also:
Fixed In Version: 1.2.4-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 03:04:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2008-07-18 14:49:52 EDT
Description of problem:
Yum upgrade fails due to gnome-python2-gtkmozembed requiring gecko-libs = 1.9

Version-Release number of selected component (if applicable):
gnome-python2-extras-2.19.1-16

How reproducible:
Every time

Steps to Reproduce:
1. yum upgrade
  
Actual results:
Error: Missing Dependency: gecko-libs = 1.9 is needed by package
gnome-python2-gtkmozembed-2.19.1-16.fc9.x86_64 (installed)
Comment 1 Orlando Arias 2008-07-19 02:58:53 EDT
Confirming bug here. Had to uninstall exaile (only program that depends on
gnome-python2-gtkmozembed) on my system in order to update. I don't use it
anyway. Might not be able to say the same thing about my father, as he might be
using exaile though.
Comment 2 Johan Cwiklinski 2008-07-19 05:06:27 EDT
Same here. 

Also, update on my x86_64 system try to install xulrunner.i386 and all its
dependencies :

# LANG=C yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package yelp.x86_64 0:2.22.1-4.fc9 set to be updated
--> Processing Dependency: gecko-libs = 1.9 for package: gnome-python2-gtkmozembed
---> Package firefox.x86_64 0:3.0.1-1.fc9 set to be updated
---> Package firefox-langpack-fr.x86_64 1:2.0-3.0.1.fc9.remi set to be updated
---> Package xulrunner.x86_64 0:1.9.0.1-1.fc9 set to be updated
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.60.beta5.fc9 set to be updated
--> Processing Dependency: libpangocairo-1.0.so.0 for package: xulrunner
--> Processing Dependency: libgconf-2.so.4 for package: xulrunner
--> Processing Dependency: libXft.so.2 for package: xulrunner
--> Processing Dependency: libgdk_pixbuf-2.0.so.0 for package: xulrunner
--> Processing Dependency: libXt.so.6 for package: xulrunner
--> Processing Dependency: libbonobo-activation.so.4 for package: xulrunner
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: xulrunner
--> Processing Dependency: libpangoft2-1.0.so.0 for package: xulrunner
--> Processing Dependency: libgnome-2.so.0 for package: xulrunner
--> Processing Dependency: libpango-1.0.so.0 for package: xulrunner
--> Processing Dependency: libstdc++.so.6 for package: xulrunner
--> Processing Dependency: libgnomevfs-2.so.0 for package: xulrunner
--> Processing Dependency: libgtk-x11-2.0.so.0 for package: xulrunner
--> Processing Dependency: libbonobo-2.so.0 for package: xulrunner
--> Processing Dependency: libcairo.so.2 for package: xulrunner
--> Processing Dependency: libgdk-x11-2.0.so.0 for package: xulrunner
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: xulrunner
--> Processing Dependency: libhunspell.so.1 for package: xulrunner
--> Processing Dependency: libdbus-glib-1.so.2 for package: xulrunner
--> Running transaction check
---> Package dbus-glib.i386 0:0.74-8.fc9 set to be updated
---> Package pango.i386 0:1.20.4-1.fc9 set to be updated
---> Package hunspell.i386 0:1.2.1-7.fc9 set to be updated
---> Package libstdc++.i386 0:4.3.0-8 set to be updated
---> Package libXft.i386 0:2.1.12-5.fc9 set to be updated
---> Package gtk2.i386 0:2.12.11-1.fc9 set to be updated
--> Processing Dependency: libXrandr.so.2 for package: gtk2
--> Processing Dependency: libXcursor.so.1 for package: gtk2
--> Processing Dependency: libXcomposite.so.1 for package: gtk2
--> Processing Dependency: libtiff.so.3 for package: gtk2
--> Processing Dependency: libXi.so.6 for package: gtk2
--> Processing Dependency: libcups.so.2 for package: gtk2
--> Processing Dependency: libXfixes.so.3 for package: gtk2
--> Processing Dependency: libXinerama.so.1 for package: gtk2
---> Package cairo.i386 0:1.6.4-1.fc9 set to be updated
---> Package libbonobo.i386 0:2.22.0-2.fc9 set to be updated
--> Processing Dependency: libxml2.so.2 for package: libbonobo
---> Package GConf2.i386 0:2.22.0-1.fc9 set to be updated
---> Package libXt.i386 0:1.0.4-5.fc9 set to be updated
---> Package gnome-vfs2.i386 0:2.22.0-1.fc9 set to be updated
---> Package libgnome.i386 0:2.22.0-3.fc9 set to be updated
--> Running transaction check
---> Package libXrandr.i386 0:1.2.2-3.fc9 set to be updated
---> Package libXinerama.i386 0:1.0.3-1.fc9 set to be updated
---> Package libxml2.i386 0:2.6.32-2.fc9 set to be updated
---> Package libtiff.i386 0:3.8.2-10.fc9 set to be updated
---> Package libXfixes.i386 0:4.0.3-3.fc9 set to be updated
---> Package cups-libs.i386 1:1.3.7-8.fc9 set to be updated
--> Processing Dependency: libgnutls.so.13 for package: cups-libs
--> Processing Dependency: libgnutls.so.13(GNUTLS_1_3) for package: cups-libs
---> Package libXcomposite.i386 0:0.4.0-4.fc9 set to be updated
---> Package libXi.i386 0:1.1.3-4.fc9 set to be updated
---> Package libXcursor.i386 0:1.1.9-2.fc9 set to be updated
--> Running transaction check
---> Package gnutls.i386 0:2.0.4-3.fc9 set to be updated
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: gnutls
--> Processing Dependency: libgpg-error.so.0 for package: gnutls
--> Processing Dependency: libgcrypt.so.11 for package: gnutls
--> Running transaction check
---> Package libgpg-error.i386 0:1.6-2 set to be updated
---> Package libgcrypt.i386 0:1.4.0-3 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 firefox                 x86_64     3.0.1-1.fc9      updates           9.3 M
 firefox-langpack-fr     x86_64     1:2.0-3.0.1.fc9.remi  remi              615 k
 xulrunner               x86_64     1.9.0.1-1.fc9    updates           8.7 M
 yelp                    x86_64     2.22.1-4.fc9     updates           876 k
Installing for dependencies:
 GConf2                  i386       2.22.0-1.fc9     fedora            1.6 M
 cairo                   i386       1.6.4-1.fc9      fedora            548 k
 cups-libs               i386       1:1.3.7-8.fc9    updates           200 k
 dbus-glib               i386       0.74-8.fc9       updates           165 k
 gnome-vfs2              i386       2.22.0-1.fc9     fedora            1.1 M
 gnutls                  i386       2.0.4-3.fc9      updates           371 k
 gtk2                    i386       2.12.11-1.fc9    updates           6.8 M
 hunspell                i386       1.2.1-7.fc9      updates           186 k
 libXcomposite           i386       0.4.0-4.fc9      fedora             14 k
 libXcursor              i386       1.1.9-2.fc9      fedora             29 k
 libXfixes               i386       4.0.3-3.fc9      fedora             14 k
 libXft                  i386       2.1.12-5.fc9     fedora             45 k
 libXi                   i386       1.1.3-4.fc9      fedora             28 k
 libXinerama             i386       1.0.3-1.fc9      fedora             13 k
 libXrandr               i386       1.2.2-3.fc9      fedora             21 k
 libXt                   i386       1.0.4-5.fc9      fedora            173 k
 libbonobo               i386       2.22.0-2.fc9     fedora            475 k
 libgcrypt               i386       1.4.0-3          fedora            215 k
 libgnome                i386       2.22.0-3.fc9     fedora            977 k
 libgpg-error            i386       1.6-2            fedora             65 k
 libstdc++               i386       4.3.0-8          fedora            317 k
 libtiff                 i386       3.8.2-10.fc9     fedora            311 k
 libxml2                 i386       2.6.32-2.fc9     updates           847 k
 pango                   i386       1.20.4-1.fc9     updates           362 k
 xulrunner               i386       1.9-0.60.beta5.fc9  fedora            8.9 M

Transaction Summary
=============================================================================
Install     25 Package(s)
Update       4 Package(s)
Remove       0 Package(s)
Comment 3 Paul W. Frields 2008-07-19 12:18:06 EDT
An update is in bodhi for this.  In the meantime you can pick up the new
packages in koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=56707 
Comment 4 Pablo Iranzo Gómez 2008-07-19 16:49:53 EDT
*** Bug 455956 has been marked as a duplicate of this bug. ***
Comment 5 Matěj Cepl 2008-07-20 03:39:41 EDT
*** Bug 455936 has been marked as a duplicate of this bug. ***
Comment 6 Paul W. Frields 2008-07-21 13:23:53 EDT
*** Bug 455971 has been marked as a duplicate of this bug. ***
Comment 7 Jeroenverh 2008-07-21 18:27:29 EDT
Have the same problem here. Hope that it can be fixed.
Comment 8 Matěj Cepl 2008-07-21 18:52:14 EDT
*** Bug 455947 has been marked as a duplicate of this bug. ***
Comment 9 Johan Cwiklinski 2008-07-21 23:23:37 EDT
I have the exactly same problem with rawhide... Did you pushed also .fc10 release ?

Thanks,
Johan
Comment 10 Kir Kolyshkin 2008-07-22 06:01:24 EDT
Same problem here, suffer for a few days already.
Comment 11 Fedora Update System 2008-07-23 03:04:21 EDT
Miro-1.2.4-2.fc9, gnome-python2-extras-2.19.1-17.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.