Bug 455919 - HA-LVM: Will not start on ia64, looking for initrd in wrong directory.
HA-LVM: Will not start on ia64, looking for initrd in wrong directory.
Status: CLOSED NOTABUG
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On: 446260
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-18 15:10 EDT by Dean Jansa
Modified: 2009-04-16 15:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-18 15:15:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Jansa 2008-07-18 15:10:38 EDT
+++ This bug was initially created as a clone of Bug #446260 +++

Description of problem:

HA-LVM will not run on ia64 due to the lvm.sh script looking for initrd in /boot
rather than /boot/efi/efi/redhat.   The resulting error in /var/log/messages is:
 May 13 14:26:42 link-14 clurgmgrd: [5556]: <err> HA LVM requires the initrd
image to be newer than lvm.conf


From lvm.sh:

 # Fixme: we might be able to perform a better check...
        if [ "$(find /boot/*.img -newer /etc/lvm/lvm.conf)" == "" ]; then
                ocf_log err "HA LVM requires the initrd image to be newer than
lvm.conf"
                return $OCF_ERR_GENERIC
        fi


The path in the find needs to be changed for ia64 or something along the lines of:

find /boot -name *.img -newer /etc/lvm/lvm.conf

which should work on all archs.

That find seems a bit suspect as well, as it finds any initrd which is newer
than lvm.conf.  Shouldn't it check the one you booted with is newer?

-- Additional comment from jbrassow@redhat.com on 2008-05-14 14:08 EST --
"That find seems a bit suspect as well, as it finds any initrd which is newer
than lvm.conf.  Shouldn't it check the one you booted with is newer?"

Yes, it should; but how do you find out which initrd was used?  I suppose you
could look in grub... gets a bit crazy.  Perhaps we can start with your suggestion.
Comment 1 Dean Jansa 2008-07-18 15:13:21 EDT
The check is still looking in the wrong spot in ia64:


lvm.sh: if [ "$(find /boot/*.img -newer /etc/lvm/lvm.conf)" == "" ]; then

rgmanager-1.9.80-1
RHEL4-U7-re20080703.3 tree
Comment 2 Dean Jansa 2008-07-18 15:15:02 EDT
Oops, there was a clone for RHEL4 already -- closing.

Note You need to log in before you can comment on or make changes to this bug.