Bug 455959 - kernel-headers-2.6.25.10-86.fc9.i386.rpm is badly messed up
kernel-headers-2.6.25.10-86.fc9.i386.rpm is badly messed up
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-19 06:39 EDT by Steve Underwood
Modified: 2008-07-24 14:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 14:02:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Underwood 2008-07-19 06:39:58 EDT
I have working Fedora 9 x86_64 and i386 machines. Today the kernels on both
machines were upgraded to 2.6.25.10-86. After this the x86_64 machine worked
fine, but the i386 machine had all the header files in /usr/include/asm jumbled
up. That is, the file names and the file contents did not match.

I found a copy of kernel-headers-2.6.25.9-76.fc9.i386.rpm, and put that back on
the i386 machine. I can now successfully compile my code once again.
Comment 1 Steve Underwood 2008-07-24 14:02:20 EDT
It looks like this was an unfortunate coincidence. It seems there was minor
corruption of the file system. After a full fsck, and a cleanup of the couple of
issues it found, the kernel-headers RPM installed OK. Of course, that doesn't
explain how the file system became corrupted without any hardware errors being
reported, but it seems to been the current bug report is spurious.

Note You need to log in before you can comment on or make changes to this bug.