Bug 455975 - If firefox starts when you start your session kde, then it does not work flash
If firefox starts when you start your session kde, then it does not work flash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
9
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-19 12:17 EDT by ruslan
Modified: 2009-05-01 07:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 04:38:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 167373 None None None Never

  None (edit)
Description ruslan 2008-07-19 12:17:13 EDT
If firefox starts when start my session kde, then it does not work flash.
In normal startup everything is fine.
 
Observed in 3.0.0 and 3.0.1


# rpm -qa | grep firefox
firefox-3.0.1-1.fc9.i386

]# rpm -qa | grep nspluginwrapper
nspluginwrapper-1.1.0-3.fc9.i386
Comment 1 Matěj Cepl 2008-07-22 02:52:51 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Could we get output of a command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

and the output of commands

	mozilla-plugin-config -f -c
	mozilla-plugin-config -l

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 ruslan 2008-07-22 15:36:43 EDT
[root@ruslan ~]# rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*
nspluginwrapper-1.1.0-3.fc9.i386
xulrunner-1.9.0.1-1.fc9.i386
alsa-plugins-jack-1.0.16-4.fc9.i386
alsa-plugins-upmix-1.0.16-4.fc9.i386
java-1.6.0-openjdk-plugin-1.6.0.0-0.16.b09.fc9.i386
alsa-plugins-samplerate-1.0.16-4.fc9.i386
alsa-plugins-vdownmix-1.0.16-4.fc9.i386
xulrunner-devel-1.9.0.1-1.fc9.i386
gallery2-flashvideo-2.2.5-1.fc9.noarch
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
mozilla-filesystem-1.9-2.fc9.i386
libflashsupport-000-0.5.svn20070904.i386
totem-mozplugin-2.23.2-5.fc9.i386
audacious-plugins-1.4.5-1.fc9.i386
setroubleshoot-plugins-2.0.4-5.fc9.noarch
flashrom-0-0.9.20080517svn3332.fc9.i386
gyachi-plugin-gpgme-1.1.35-6.fc9.i386
firefox-3.0.1-1.fc9.i386
alsa-plugins-oss-1.0.16-4.fc9.i386
alsa-plugins-pulseaudio-1.0.16-4.fc9.i386
gstreamer-plugins-flumpegdemux-0.10.15-2.fc9.i386
flash-plugin-9.0.115.0-release.i386
gstreamer-plugins-good-0.10.8-7.fc9.i386
gstreamer-plugins-base-0.10.19-2.fc9.i386
[root@ruslan ~]#

[ruslan@ruslan ~]$ mozilla-plugin-config -f -c
*** NSPlugin Viewer  *** ERROR:
/usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so: undefined
symbol: __gxx_personality_v0
[ruslan@ruslan ~]$

[root@ruslan ~]# mozilla-plugin-config -f -c
*** NSPlugin Viewer  *** ERROR:
/usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so: undefined
symbol: __gxx_personality_v0
[root@ruslan ~]#

[root@ruslan ~]# mozilla-plugin-config -l
EXCLUDE_WRAP:
libtotem*
libjavaplugin*
gecko-mediaplayer*
mplayerplug-in*
EXCLUDE_LINK:

File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.libflashplayer.so
  Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
  Wrapper version string: 1.1.0
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/librhythmbox-itms-detection-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libjavaplugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so
[root@ruslan ~]#

[ruslan@ruslan ~]$ mozilla-plugin-config -l
EXCLUDE_WRAP:
libtotem*
libjavaplugin*
gecko-mediaplayer*
mplayerplug-in*
EXCLUDE_LINK:

File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-complex-plugin.xpt
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.libflashplayer.so
  Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
  Wrapper version string: 1.1.0
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-cone-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-basic-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/librhythmbox-itms-detection-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.xpt
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-mully-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libjavaplugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-gmp-plugin.so
File/Link /usr/lib/mozilla/plugins-wrapped/libtotem-narrowspace-plugin.so
[ruslan@ruslan ~]$

Comment 3 Rex Dieter 2008-07-24 08:40:31 EDT
report upstream to bugs.kde.org please.
Comment 4 Rex Dieter 2008-07-24 16:45:03 EDT
kde's session manager tries to restart
restartCommand6=/usr/lib/firefox-3.0.1/firefox 
which is the kicker here.

any short-term workarounds (or long-term ideas) to make firefox not rely on the
sh wrapper /usr/bin/firefox to function properly?
Comment 5 Martin Stransky 2008-07-25 04:38:38 EDT
Official firefox launcher is /usr/bin/firefox. Use it. The
/usr/lib/firefox-3.0.1 patch is changing after each firefox update so you can't
rely on it. Closing as WONTFIX.
Comment 6 Rex Dieter 2008-07-25 10:18:24 EDT
firefox is going to rely on an app-wrapper to function properly for the
foreseeable future (ie, no plans to address this)?   Do other platforms rely on
a app-wrapper too (Windows, MacOS)?

further, I've argued for a long time that changing installdir (e.g.
/usr/lib/firefox-%{version}) for every version iteration isn't a good idea
packaging-wise.
Comment 7 Rex Dieter 2008-09-04 10:13:56 EDT

*** This bug has been marked as a duplicate of bug 437596 ***
Comment 8 ruslan 2009-05-01 07:50:22 EDT
Rawhide,

firefox-3.1-0.11.beta3.fc11.i586,

KDE-4.2.2

If firefox starts when start my session kde, then now it work flash.
Thanks. Good work

Note You need to log in before you can comment on or make changes to this bug.