Bug 45604 - shutdown kills raid daemon before drives get unmounted
shutdown kills raid daemon before drives get unmounted
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-23 00:35 EDT by Christopher Hicks
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:35:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/raidtab (372 bytes, text/plain)
2001-06-23 00:38 EDT, Christopher Hicks
no flags Details
output of mount (339 bytes, text/plain)
2001-06-23 00:39 EDT, Christopher Hicks
no flags Details

  None (edit)
Description Christopher Hicks 2001-06-23 00:35:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.13 i686)

Description of problem:
During shutdown it gets to "Sending all processes the KILL signal..."
Then there are some messages from the raid system:
	raid5d(122) flushing signals.
	md: recovery thread got woken up ...
	md: recovery thread finished ....
	mdrecoveryd(8) flushing signals.
	md_do_sync() got signal ....exiting
	raid5: resync aborted!

When it gets down to Unmounting file systems it hangs.  I presume this is
because the raid daemon is dead by then.  The filesystem on the RAID is
reiserfs, so it's not that big a deal to hit reset and let the box come
back up.  But it's annoying that it hangs and it does take a minute for the
ext2 file systems (/ and /boot) to clean themselves up.

How reproducible:
Didn't try

Steps to Reproduce:
I don't have any other systems with RAID drives so I can't say that I've
reproduced it.  But it does do it

Expected Results:  I would have expected the box to shutdown cleanly.

Additional info:

I've installed all the updates after doing a clean install on this box.

I had RH6.2 and an ext2 filesystem on a RAID in this system before without
any trouble.
Comment 1 Christopher Hicks 2001-06-23 00:38:17 EDT
Created attachment 21626 [details]
/etc/raidtab
Comment 2 Christopher Hicks 2001-06-23 00:39:24 EDT
Created attachment 21627 [details]
output of mount
Comment 3 Elliot Lee 2001-09-20 19:50:30 EDT
Hangs usually only happen when unmounting NFS file systems - just sit and wait
for things to happen.

Sorry, that's about the only explanation I can think of besides slow hardware,
which you probably would have already factored in.

Note You need to log in before you can comment on or make changes to this bug.