This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 45607 - Resizing the xchat window crashes X
Resizing the xchat window crashes X
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-23 11:02 EDT by alien_life_form
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-30 09:30:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X configuration (4.60 KB, text/plain)
2001-06-30 09:30 EDT, alien_life_form
no flags Details

  None (edit)
Description alien_life_form 2001-06-23 11:02:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)

Description of problem:
Running the SVGA server, (ATI Rage) running xchat and then resizing the
xchat window hangs or crashes X completely (keyboard/mouse unresponsive).
Machine can still be reached through the LAN. I tried this under
gnome/sawmill and KDE and with xchat-1.6.3-4 and xchat-1.7.8.1 (RPM from
xchat.org)  

How reproducible:
Always

Steps to Reproduce:
1. run xchat
2. pull on the lower right corner, resize
3. b00m
	

Additional info:
Comment 1 alien_life_form 2001-06-26 13:39:44 EDT
I just verified that xchat-1.4.0-1 (from the RH6.2 distribution) does *not*
have the same problem.
Comment 2 Havoc Pennington 2001-06-26 13:59:04 EDT
Probably a bug in the ATI server.
Comment 3 Mike A. Harris 2001-06-29 17:28:45 EDT
Are you running the recently released XFree86 3.3.6-29 errata release?
If not, please upgrade to 3.3.6-29 and see if the problem goes away.

Out of curiousity, why are you not using XFree86 4.0.3?
Comment 4 Alexei Podtelezhnikov 2001-06-29 19:33:25 EDT
This bug report is posted using RH 6.2. Mozilla 4.72 and Linux 2.2.14-5.0 
tells me exactly that. This system need all updates first. Very confusing.
Is this really RH 7.1 bug?
Comment 5 Mike A. Harris 2001-06-29 21:42:13 EDT
Quite often the system someone uses to report a bug isn't necessarily the
one that has the bug.  Also a lot of people dualboot old/new distro releases
to migrate, test the waters, etc..  One thing though - I mentioned the -29
release...  That is for 6.2..  The 3.3.6 errata for 7.x is
XFree86-Servers-3.3.6-38.src.rpm and friends..  Sorry for any confusion.

Just to clarify though - what distro release are you using, and what release of
xchat?
Comment 6 alien_life_form 2001-06-30 07:39:30 EDT
I am running
XFree86-4.0.3-5
XFree86-SVGA-3.3.6-38

The problem was verified with:

xchat-1.6.3-4 and 
xchat-1.7.8.1 

(RPM from xchat.org)  

And, I posted the bug report from a random machine in the room (as the 7.1 box
was  locked up 
by the bug). In fact, I could as easily have been posting from one of the NT
boxes, which I now realize would have been cause of alarm.... ;-)
Comment 7 Mike A. Harris 2001-06-30 07:59:18 EDT
If any application causes the machine to lock, it is definitely not an
application bug, so it shouldn't matter what xchat you use.  It almost 
certainly is an X server bug of some kind.

I will need you to provide me with individual file attachments of your
X server logs and config files using the link below.
Comment 8 alien_life_form 2001-06-30 09:30:28 EDT
Created attachment 22286 [details]
X configuration
Comment 9 alien_life_form 2001-06-30 09:41:14 EDT
I just sent you my X config.
But in all fairness, I must admit that today, having re-created the scenario of
the lock ups for the purpose of creaitinga a crash log, I have been unable two
re-enact the crashes, though I could recreate  them at will when I submitted the
report. 

Wether it's cosmic rays, some update that's been installed without my
knowledge/consent in the meanwhile, or something even weirder (hardware related,
for instance) I cannot say. (I would not rule out the 'weird' thing: X has
always been acting funny o this particular machine - though windows does not).

I'd guess this sorta disqualifies this incident for further investigation. Sorry
for the waste of time - mine and yours.


Cheers,

Note You need to log in before you can comment on or make changes to this bug.