Bug 456091 - dhclient: failed to set close-on-exec for /var/lib/dhclient/dhclient-eth0.leases
dhclient: failed to set close-on-exec for /var/lib/dhclient/dhclient-eth0.leases
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-07-21 10:19 EDT by Jonathan Kamens
Modified: 2008-08-01 20:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 20:50:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-07-21 10:19:42 EDT
dhclient is logging "failed to set close-on-exec for
/var/lib/dhclient/dhclient-eth0.leases".  Since there's no reason why dhclient
should be unable to set close-on-exec on a file descriptor for a regular file
such as dhclient-eth0.leases, there must be a bug in the code.
Comment 1 Bill Nottingham 2008-07-25 10:17:21 EDT
Any AVC messages if you're running with SELinux?
Comment 2 Jonathan Kamens 2008-07-25 10:22:14 EDT
SELinux is disabled.  Don't know what "AVC messages" are.
Comment 3 Will Woods 2008-07-29 17:29:48 EDT
I've seen this on my F9 system, with SELinux enabled. No AVC denials logged.
Comment 4 David Cantrell 2008-08-01 20:50:59 EDT
This should be fixed in rawhide in dhcp-4.0.0-17.fc10.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.