Bug 45610 - ntop does not collect data
ntop does not collect data
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: ntop (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-23 15:29 EDT by Dmitri A. Sergatskov
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 07:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri A. Sergatskov 2001-06-23 15:29:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12smp i686)

Description of problem:
ntop does not collect any data. 

How reproducible:
Always

Steps to Reproduce:
1.run ntop (/etc/init.d/ntop start)
2.go to http://localhost:3000
3.Click on "IP traffic" and then chose any of L-L, L-R

	

Actual Results:  You will see "No data collected yet" (though program was
runnig for few days) 
	

Expected Results:  Matrix of traffic between hosts on the subnet

Additional info:

This error is reported on ntop.org and suggested solution is that:
"RedHat has broken libpcap, get a prestine source and recompile against
it". I have not done it since I do not believe that RedHat would ship a
broken libpcap :)
Comment 1 Dmitri A. Sergatskov 2001-06-30 19:05:18 EDT
It appears that it does collect some data, e.g. "Data Rcvd" top menu
shows some data (on all sidebar selections: "All Protocols", "IP" etc..).
"Data Sent" works as well. For "IP Traffic" only "Local Usage" and "L->R"
shows something. "Matrix", "L<->L", "R->L" do not show any data ("No Data To
Display (yet)").
Comment 2 Patrick C. F. Ernzer 2001-08-21 12:23:50 EDT
On a fully updated RHL 6.2 (using up2date today) gtop does not collect any data
either.
Comment 3 Patrick C. F. Ernzer 2001-08-22 07:39:49 EDT
further to my previous comment:

rebuilding libpcap-0.6.2-7.i386.rpm and ntop-1.3.1-1.i386.rpm from source seems to solve the problem.
Comment 4 Ngo Than 2001-08-22 16:12:56 EDT
update libpcap-0.6.2-7 in rawhide should fix this problem
Comment 5 Dmitri A. Sergatskov 2001-09-03 16:19:42 EDT
CAnnot find libpcap in rawhide:
ncftp ...ux/rawhide/SRPMS/SRPMS > ls lib*
libao-0.8.0-1.src.rpm                  librep-0.13.6-5.src.rpm
libcap-1.10-5.src.rpm                  librsvg-1.0.0-7.src.rpm
libelf-0.7.0-1.src.rpm                 libsigc++-1.0.3-5.src.rpm
libesmtp-0.8.4-1.src.rpm               libtabe-0.2-6.src.rpm
libffi-20010609-1.src.rpm              libtermcap-2.0.8-28.src.rpm
libgcj-2.96-26.src.rpm                 libtiff-3.5.5-12.src.rpm
libghttp-1.0.9-2.src.rpm               libtool-1.4-8.src.rpm
libglade-0.16-4.src.rpm                libtool-libs13-1.3.5-2.src.rpm
libgtop-1.0.12-4.src.rpm               libungif-4.1.0-9.src.rpm
libjpeg6a-6a-8.src.rpm                 libunicode-0.4-6.src.rpm
libjpeg-6b-16.src.rpm                  libuser-0.29-1.src.rpm
libmng-1.0.2-1.src.rpm                 libvorbis-1.0rc2-2.src.rpm
libodbc++-0.2.2pre4-12.src.rpm         libxml10-1.0.0-8.src.rpm
libogg-1.0rc2-1.src.rpm                libxml-1.8.14-2.src.rpm
libole2-0.2.3-1.src.rpm                libxml2-2.4.2-1.src.rpm
libpng-1.0.12-2.src.rpm                libxslt-1.0.1-3.src.rpm
libPropList-0.10.1-8.src.rpm
Comment 6 Patrick C. F. Ernzer 2001-09-13 08:47:46 EDT
libpcap is built from tcpdump-<version>.src.rpm

Note You need to log in before you can comment on or make changes to this bug.