Bug 456149 - route add fails with error "SIOCADDRT: No such process\n"
route add fails with error "SIOCADDRT: No such process\n"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: net-tools (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Radek Vokal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-21 14:52 EDT by John Poelstra
Modified: 2008-08-01 05:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 05:18:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace (6.05 KB, text/plain)
2008-07-21 14:52 EDT, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2008-07-21 14:52:31 EDT
Description of problem:

route add fails with error "SIOCADDRT: No such process\n" with my wireless
connection. I've seen it several times in /var/log/messaes resulting in my
notebook being unable to automatically set a default route and get outside my
local network

Version-Release number of selected component (if applicable):
net-tools-1.60-87.fc9.i386

How reproducible:
100%

Steps to Reproduce:
1. make sure wired network port is not connected
2. # route add default gw 192.168.1.10
3.
  
Actual results:
error

Expected results:
success

Additional info:
see attched strace log
Comment 1 John Poelstra 2008-07-21 14:52:31 EDT
Created attachment 312291 [details]
strace
Comment 2 John Poelstra 2008-07-21 14:55:44 EDT
note the wired network also does not work correctly with NetworkManager in that
a default route is not set automatically.  What is unique about the wired
network is that I CAN manually set the default route.
Comment 3 Zdenek Prikryl 2008-07-29 08:32:44 EDT
Please, can you describe here whole configuration of your network? I neam IP,
netmask, ...

Thanks.
Comment 4 John Poelstra 2008-07-31 14:12:44 EDT
After researching this further I have found that the problem appears to be with
my dhcp server (linksys running openwrt).  I was using static dhcp assignments
and when I disable the MAC address association everything works fine.  My
current theory is that I have a some stale MAC address associations that I can't
clear out of the router for some reason.

Is this still a bug?  IOW should 'route' return the error it does if it can't
set a route?
Comment 5 Zdenek Prikryl 2008-08-01 05:18:50 EDT
In my opinion, this is the configuration error, not a error in net-tools.
Returned error message reflect the problem which was caused by setting wrong
route, so I think that there is no problem with it. In any case I'm closing this
as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.