Bug 456153 - xorg-x11-server doesn't build in rawhide
xorg-x11-server doesn't build in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-21 15:24 EDT by Sven Lankes
Modified: 2008-07-31 10:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 10:20:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven Lankes 2008-07-21 15:24:42 EDT
Description of problem:

xorg-x11-server doesn't build because of two things:

 1. the configure script checks for trapproto which is no longer available in
the current xorg-x11-proto-devel
 2. after fixing the above (by installing an older x11-proto-devel) the
compilation fails with "dri2.c:398: error: 'DRM_BO_FLAG_READ' undeclared".
According to http://lists.freedesktop.org/archives/xorg/2008-July/036894.html
--disable-dri2 is needed. Adding this results in a successful build.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.4.99.905-2.20080701.fc10.i386
xorg-x11-proto-devel-7.4-1.fc10.noarch

How reproducible:

rpmbuild, scratch-build in koji

Steps to Reproduce:
1. see http://koji.fedoraproject.org/koji/taskinfo?taskID=730627
Comment 1 Adam Jackson 2008-07-31 10:20:53 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.