Bug 456192 - [RFE]Customer need kdump to dump kernel pages only.
[RFE]Customer need kdump to dump kernel pages only.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Neil Horman
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-21 23:09 EDT by Zhenyong(Jerry) Jiang
Modified: 2013-07-28 20:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 07:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhenyong(Jerry) Jiang 2008-07-21 23:09:21 EDT
Description of problem:

Anderson wrote kdump can support full dump or kernelpages only dump in
http://www.linuxsymposium.org/2006/kdump_slides.pdf

But in RHEL5.2 kernel-doc, kdump.txt says this function is in "TO DO" list. will
we bring this function into RHEL5.3?

in some of my cases, some servers has 16GB or more memory, a full dump will
create a huge file. It will cost 1-2 days to transfer it to redhat.

Some other customers want to protect their data, they wishes kdump not collect
the user-space pages. They know disk-dump can support it in RHEL4.

Could we implement it in RHEL5.3.
Comment 1 Neil Horman 2008-07-23 07:18:14 EDT
This has been implemented since GA iirc, using the makedumpfile utility, which
is configurable automatically through kdump using the core_collector option in
/etc/kdump.conf.  See man makedumpfile (specifically the -d option) for details
of usage

Note You need to log in before you can comment on or make changes to this bug.