Bug 456193 - firefox-3 does not respond to URLS clicked in thunderbird-1.5
firefox-3 does not respond to URLS clicked in thunderbird-1.5
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: thunderbird (Show other bugs)
4.7
All Linux
urgent Severity high
: rc
: ---
Assigned To: Martin Stransky
desktop-bugs@redhat.com
: Regression, ZStream
: 456619 459093 (view as bug list)
Depends On: 456326
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-21 23:10 EDT by Ben Levenson
Modified: 2010-10-22 23:01 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 16:51:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2008-07-21 23:10:43 EDT
Description of problem:
firefox-3 does not respond to URLS clicked in thunderbird-1.5

1- install ff3
2- make it the default browser
3- click on a link in thunderbird - NOTHING
4- click on a link in pidgin - WORKS
5- click on a link in evo28 - WORKS

Version-Release number of selected component (if applicable):
$ rpm -q thunderbird firefox
thunderbird-1.5.0.12-11.el4
firefox-3.0.1-1.el4

(possibly related to bug 456189)
Comment 1 Ben Levenson 2008-07-21 23:19:04 EDT
additional info: thunderbird-1.5 + firefox-1.5 work as expected
Comment 2 Matěj Cepl 2008-07-25 01:20:37 EDT
Is https URLs only, or any URL?
Comment 3 Matěj Cepl 2008-07-25 01:21:04 EDT
Gosh,
*It is https URL, ...
Comment 4 Matěj Cepl 2008-07-25 01:21:33 EDT
OK, the last try:
*Is it https URLs ...
Comment 5 Ben Levenson 2008-07-28 01:26:02 EDT
The https issue was just with thunderbird.
At 4.7 GA, thunderbird would not properly launch ff3 under any circumstances,
but this might have been fixed when stransky tweaked the startup script to fix
the plugin directory bug... I'll have to retest when I get back to my 4.7 box.
Comment 6 Dennixx 2008-07-30 03:25:25 EDT
I have the same problem here after firefox the last firefox and thunderbird errata.

I tried clicking on ftp://, http:// and https:// URLs in thunderbird, but no
firefox gets started.
Comment 8 RHEL Product and Program Management 2008-08-01 11:05:48 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 9 Matěj Cepl 2008-08-01 11:33:05 EDT
Theoretically thunderbird should as a reaction to click on URL run application
specified in the config variable network.protocol-handler.app.http which is set
on all RH platforms AFAIK to /usr/lib/thunderbird-{version}/open-browser.sh.

When I put into this script two lines (around line 55 after GCONF and NEEDTERM
values are found) writing values of the variables GCONF and NEEDTERM to the file
in /tmp. However, when clicking on the link in TB, this file was not even created.
Comment 11 Ben Levenson 2008-08-01 13:49:38 EDT
I think thunderbird-1.5 needs to be rebuilt against the latest nss/nspr versions.
The problem goes away if I do the following:
1- move all of the nss/nspr libs out of /usr/lib/thunderbird-1.5*
2- force thunderbird to start with the new nss/nspr packages

this is related to bug 456619
Comment 16 Kai Engert (:kaie) 2008-08-05 13:13:18 EDT
Yes, this is a duplicate of bug 456619. But I'll mark 456619 as a dupe of this one, because this one already has acks.

The proposed solution in comment 11 is the right thing to do.
Chris, Martin, are you able to work on this? Thanks.
Comment 17 Kai Engert (:kaie) 2008-08-05 13:15:30 EDT
*** Bug 456619 has been marked as a duplicate of this bug. ***
Comment 24 Martin Stransky 2008-08-14 08:27:08 EDT
The package is here:

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=1431346
Comment 34 Philip Durbin 2008-08-27 09:26:49 EDT
A colleague of mine has posted a work around to this problem, which involves unsetting LD_LIBRARY_PATH.  The topic is RHEL 5 but it works on RHEL 4 as well:

Thunderbird will not open links (RHEL 5.1)
http://forums.mozillazine.org/viewtopic.php?f=39&t=804235&p=4279215#p4279215
Comment 38 Issue Tracker 2008-09-02 12:46:38 EDT
Ok. The -15 packages seem to resolve the issue. I'll pass them over to the
customer and let you know if he runs into any problems with them in his
environment.

Thanks.


This event sent from IssueTracker by kbaxley 
 issue 194993
Comment 39 Issue Tracker 2008-09-04 13:30:16 EDT
Customer confirms that the new nss packages and thunderbird-1.5.0.12-15 fix
their issue.

Is there a time frame available for releasing fixes for these?

Thanks.


This event sent from IssueTracker by kbaxley 
 issue 194993
Comment 40 Kai Engert (:kaie) 2008-09-05 15:22:26 EDT
Tao, I think Martin should comment on his plans for releasing the fix.

It seems this bug is approved for RHEL 4.8, so I'd assume that's the release schedule.

I don't know whether Chris/Martin plan to release in some kind of z-stream channel.
Comment 41 Martin Stransky 2008-09-19 07:42:08 EDT
It's already in cvs and it's going to be released with the next thunderbird security update.
Comment 42 Martin Stransky 2008-09-19 07:43:45 EDT
*** Bug 459093 has been marked as a duplicate of this bug. ***
Comment 52 Martin Stransky 2009-05-20 16:51:42 EDT
It's already fixed in thunderbird-1.5.0.12-19.el4.

Note You need to log in before you can comment on or make changes to this bug.