Bug 456227 - UnicodeDecodeError: 'ascii' codec can't decode...
UnicodeDecodeError: 'ascii' codec can't decode...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-22 08:18 EDT by Stefan Posdzich
Modified: 2014-01-21 18:03 EST (History)
6 users (show)

See Also:
Fixed In Version: yum-3.2.17-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-07 16:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Posdzich 2008-07-22 08:18:35 EDT
Description of problem:

after the latest "yum update" (these packages -> http://phpfi.com/334560) , 
yum cries:

Lade Pakete herunter:
Führe rpm_check_debug durch
FEHLER mit rpm_check_debug gegen depsolve:
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 241, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 193, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 377, in doTransaction
    print msg
  File "/usr/lib/python2.5/codecs.py", line 303, in write
    data, consumed = self.encode(object, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 19: 
ordinal not in range(128)


Version-Release number of selected component (if applicable):

yum 3.2.16


How reproducible:

always.

run "yum install foobar", "yum remove foobar" etc.

  
Actual results:

yum useless, see the output


Expected results:

yum usable
Comment 1 seth vidal 2008-07-22 09:40:33 EDT
please try yum 3.2.17 from updates-testing and see if it works any better. Thanks.
Comment 2 James Antill 2008-07-22 10:02:32 EDT
 Also what locale is this? It looks like de_DE.utf-8 ... although that works
fine here with 3.2.17+ (and I'm not sure what would have changed to fix it, or
even why 3.2.16 is failing for you).
Comment 3 Stefan Posdzich 2008-07-22 10:11:25 EDT
Installed yum-3.2.17-2.fc9.noarch.rpm from updates-testing. Works fine.
This new yum should be in stable!

>> It looks like de_DE.utf-8 <<

Yes it is "de_DE.utf8"

Note You need to log in before you can comment on or make changes to this bug.