Bug 45624 - closing display on laptop while in X causes virtual terminal display corruption
closing display on laptop while in X causes virtual terminal display corruption
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-23 20:30 EDT by Andrew Weck
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-26 12:13:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Weck 2001-06-23 20:30:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
I am running RH on Dell Inspirion 4000 w/ ATI Rage Mobility (M3).  If you 
close the display while in X windows and reopen it, it will mess up the 
virtual terminal displays.  The only fix is to close the display under the 
virtual terminal and reopen it.  It then fixes the virtual terminal  
display.  If you try to switch back to X with the virtual terminal display 
messed up, it will in turn mess up the X display.

How reproducible:
Always

Steps to Reproduce:
1. Start up X windows.
2. Close the display and reopen it.
3. Try to exit X windows or switch to virtual terminal.
	

Actual Results:  The terminal should display correctly.

Expected Results:  The terminal display is corrupted.  You have to close 
and open the display under the virtual terminal to get it corrected.  If 
you switch back to X without correct the display, both display get messed 
up.  You have to correct the display under the virtual terminal if you 
want it to work under X.

Additional info:
Comment 1 Mike A. Harris 2002-07-26 12:13:48 EDT
This is most probably related to the Rage 128 VTswitch lockup in
bug #65136.  Could you do the following test:

1) Make sure DRI is enabled
2) start X
3) Run "lspci -vvn" and look for the line which shows "BusMaster+".  The "+"
   *SHOULD* be there while you're in X.
4) VTswitch out of X and log in to the console as root.
5) Run "lspci -vvn" and look for the BusMaster line again.

Is it still BusMaster+, or is it BusMaster- now?

If it is BusMaster-, then the bugfix for bug #65136 which is forthcoming
will likely fix this one too.  Please provide me with this information
ASAP so I can make sure the fix applies to this bug too.
Comment 2 Mike A. Harris 2002-09-08 06:32:55 EDT
Assuming due to lack of response that the problem no longer occurs after
testing with the new release.  Closing as fixed in rawhide. If the problem
persists when using XFree86 4.2.0-72 or higher, or when the next release
of Red Hat Linux is out, please reopen the bug report and provide updated
details.

Note You need to log in before you can comment on or make changes to this bug.