Bug 45628 - Kernel 2.4.3-12 on ReiserFS system
Summary: Kernel 2.4.3-12 on ReiserFS system
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-06-24 05:36 UTC by Tan Zheng Da
Modified: 2007-04-18 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 14:00:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reiserfs patch (146.48 KB, patch)
2001-06-25 07:00 UTC, Arjan van de Ven
no flags Details | Diff

Description Tan Zheng Da 2001-06-24 05:36:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2r1 i686; en-US; rv:0.9.1)
Gecko/20010608

Description of problem:
Kernel 2.4.3-12 released by Red Hat, compiled with ReiserFS into the kernel
and disabled ReiserFS internal checking, running on a root ReiserFS system.
 When system is shut down, it hangs at the stage "Unmounting file
systems:".  Pressing Ctrl-Alt-Del here gives a warning: "shutdown: warning:
cannot open /var/run/shutdown.pid".  Problem did not exist on kernel 2.4.2-2.

How reproducible:
Always

Steps to Reproduce:
1.Your system should be running ReiserFS on root partition (see
http://cambuca.ldhs.cetuc.puc-rio.br/ )
2.Install kernel-source-2.4.3-12
3.make oldconfig using configs/kernel-2.4.2-i686.config
4.make menuconfig and edit File Systems, change ReiserFS to compile into
the kernel instead of as a module.  Disable internal code checking for ReiserFS
5.Compile kernel and install kernel.
6.Reboot into new kernel 2.4.3-12
7.Log in as root
8.Run 'shutdown -h now'
	

Actual Results:  When you reach 'Unmounting file systems:' on shutdown, it
will hang. Press "Ctrl-Alt-Del". Message "shutdown: warning: cannot open
/var/run/shutdown.pid" appears.

Expected Results:  It should have shut down cleanly.  The problem was not
present when I compiled kernel 2.4.2-2 with ReiserFS support and internal
checking disabled, for the exact same system.

Additional info:

The kernel was compiled with the steps according to my own documentation at
http://www.pobox.com/~tzd/linux/gateway/3350.html

Comment 1 Tan Zheng Da 2001-06-24 05:40:32 UTC
Oops one typo.  Steps to reproduce, #3 should say:
make oldconfig using configs/kernel-2.4.3-i686.config
instead of kernel-2.4.2-i686.config.
-- tzd@pobox.com

Comment 2 Arjan van de Ven 2001-06-25 06:41:02 UTC
investigating

Comment 3 Arjan van de Ven 2001-06-25 07:01:00 UTC
Created attachment 21726 [details]
reiserfs patch

Comment 4 Arjan van de Ven 2001-06-25 07:01:38 UTC
Could you try applying the previously attached patch to your kernelsource and
see if that makes it work ?

Comment 5 Tan Zheng Da 2001-06-25 11:27:45 UTC
Yes, the patch (id 21726) works.  I can shut down cleanly now.  Do you mind
explaining what the patch does (I don't know how to program)?  Thanks!

Comment 6 Arjan van de Ven 2001-06-25 11:36:19 UTC
It removes a bugfix that was applied to our kernel for a race on module-unload,
however the bugfix was not tested for the "reiserfs is not a module" case.
It seems it deadlocked in that case due to the locking changes in the original
bugfix.

Comment 7 Tan Zheng Da 2001-06-25 11:41:11 UTC
Thanks for the explanation.  Is it safe for me to continue using the patch?

Comment 8 Arjan van de Ven 2001-06-25 11:41:56 UTC
Yes. 


Comment 9 Tan Zheng Da 2001-06-25 11:44:17 UTC
Great!  And thanks for the speedy resolution!

Comment 10 Bruce Garlock 2001-06-26 13:14:21 UTC
I had this exact same problem.  I seem to be having an issue recompiling the 2.4.3-12 from the source RPM.  Using the binary RPM of the 2.4.3-12 
kernel supplied by RHAT, the aic7xxx_mod driver is listed in my /etc/modules.conf, as the default aic7xxx driver to use.  When I recompiled this kernel 
from the source RPM, and I try to make an initrd image, it says it cannot find the aic7xxx_mod file.  After looking through my /li/modules/2.4.3 tree, I saw 
that only aic7xxx and aic7xxx_old are compiled.

Which one should I use to boot with Justin Gibbs' aic7xxx driver?  I'm guessing the aic7xxx.o file, but I'm not sure.  Why wouldn't the aic7xxx_mod driver 
compile from the source?

Comment 11 Arjan van de Ven 2001-06-26 13:18:42 UTC
 aic7xxx.o is the new driver.
Justin Gibb's driver got renamed in Linus' / Alan's kernels, in the RPM build
we rename the driver to it's original "2.4.2-2" name to make sure our kernel rpm
keeps working for people using this driver.


Note You need to log in before you can comment on or make changes to this bug.