Bug 45630 - segfault when file-print
segfault when file-print
Status: CLOSED DUPLICATE of bug 45149
Product: Red Hat Powertools
Classification: Retired
Component: nedit (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-24 05:50 EDT by Gene Czarcinski
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-24 05:50:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-06-24 05:50:36 EDT
Red Hat Linux 7.1 and nedit 5.1.1-6 (all current errata applied).

nedit a source file and then select file-print.  nedit immediately segaults.

Here is the gdb and bt output:

GNU gdb 5.0rh-5 Red Hat Linux 7.1
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...(no debugging symbols
found)...
Core was generated by `nedit /etc/resolv.conf'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/i686/libm.so.6...done.
Loaded symbols for /lib/i686/libm.so.6
Reading symbols from /usr/X11R6/lib/libXm.so.2...done.
Loaded symbols for /usr/X11R6/lib/libXm.so.2
Reading symbols from /usr/X11R6/lib/libXpm.so.4...done.
Loaded symbols for /usr/X11R6/lib/libXpm.so.4
Reading symbols from /usr/X11R6/lib/libXext.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.6
Reading symbols from /usr/X11R6/lib/libXt.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXt.so.6
Reading symbols from /usr/X11R6/lib/libSM.so.6...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.6
Reading symbols from /usr/X11R6/lib/libICE.so.6...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.6
Reading symbols from /usr/X11R6/lib/libX11.so.6...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /lib/i686/libc.so.6...done.
Loaded symbols for /lib/i686/libc.so.6
Reading symbols from /usr/X11R6/lib/libXp.so.6...done.
Loaded symbols for /usr/X11R6/lib/libXp.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /usr/lib/gconv/ISO8859-1.so...done.
Loaded symbols for /usr/lib/gconv/ISO8859-1.so
#0  0x403b961a in __gen_tempname (tmpl=0x80a2db0 "/tmp/neditXXXXXX", kind=0)
    at ../sysdeps/posix/tempname.c:250
250
../sysdeps/posix/tempname.c: No such file or directory.
---Type <return> to continue, or q <return> to quit---
	in ../sysdeps/posix/tempname.c
(gdb) bt
#0  0x403b961a in __gen_tempname (tmpl=0x80a2db0 "/tmp/neditXXXXXX", kind=0)
    at ../sysdeps/posix/tempname.c:250
#1  0x40433ed1 in mkstemp (template=0x80a2db0 "/tmp/neditXXXXXX") at
mkstemp.c:34
#2  0x0804f7b4 in XMapRaised ()
#3  0x0804f784 in XMapRaised ()
#4  0x08053f68 in XMapRaised ()
#5  0x4023947a in XtCallActionProc () from /usr/X11R6/lib/libXt.so.6
#6  0x0805218c in XMapRaised ()
#7  0x40212716 in XtCallCallbackList () from /usr/X11R6/lib/libXt.so.6
#8  0x400dc1c2 in BtnUp () from /usr/X11R6/lib/libXm.so.2
#9  0x402416c1 in _XtMatchAtom () from /usr/X11R6/lib/libXt.so.6
#10 0x40241b7c in _XtMatchAtom () from /usr/X11R6/lib/libXt.so.6
#11 0x402420f7 in _XtTranslateEvent () from /usr/X11R6/lib/libXt.so.6
#12 0x4021de08 in XtDispatchEventToWidget () from /usr/X11R6/lib/libXt.so.6
#13 0x4021e884 in _XtOnGrabList () from /usr/X11R6/lib/libXt.so.6
#14 0x4021ead7 in XtDispatchEvent () from /usr/X11R6/lib/libXt.so.6
#15 0x4021ef12 in XtAppMainLoop () from /usr/X11R6/lib/libXt.so.6
#16 0x0804e004 in XMapRaised ()
#17 0x4036f177 in __libc_start_main (main=0x804d6d0 <XMapRaised+272>, argc=2,
    ubp_av=0xbffff934, init=0x804c2a8 <_init>, fini=0x80a0110 <_fini>,
    rtld_fini=0x4000e184 <_dl_fini>, stack_end=0xbffff92c)
    at ../sysdeps/generic/libc-start.c:129
Comment 1 Bernhard Rosenkraenzer 2001-06-25 06:11:30 EDT

*** This bug has been marked as a duplicate of 45149 ***

Note You need to log in before you can comment on or make changes to this bug.