Bug 456327 - Anaconda loader can't figure out optical drive status
Anaconda loader can't figure out optical drive status
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10KernelBlocker
  Show dependency treegraph
 
Reported: 2008-07-22 17:18 EDT by Will Woods
Modified: 2008-10-23 15:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-11.4.1.51
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 15:30:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-07-22 17:18:53 EDT
Anaconda 11.4.1.15 will get stuck trying to check the CD-ROM drive(s) for
installation media, for about 15 seconds each. The message says:

+----------------------| Scanning |--------------------+
| Looking for installation media on CD device /dev/sr0 |
+------------------------------------------------------+

I'm told this is caused by a kernel bug where sr_mod reports inaccurate status
after tray closure. 

For further info, see this thread on fedora-kernel-list, where pjones is trying
to get a fix into the upstream kernel:
https://www.redhat.com/archives/fedora-kernel-list/2008-July/msg00037.html
Comment 1 Tom Horsley 2008-10-06 20:43:49 EDT
If there is no kernel fix, any chance we could at least get a
working [Cancel] button on that anaconda screen?
Comment 2 Chuck Ebbert 2008-10-11 14:50:24 EDT
The patch to fix the CD drive status checking is in rawhide now. Can someone test it?
Comment 3 Will Woods 2008-10-13 16:01:59 EDT
Still takes ~15s to timeout on an empty drive in my test machine, using today's rawhide snapshot (kernel-2.6.27-3.fc10, anaconda-11.4.1.48).

What kernel/anaconda rev contained the patch you mention?
Comment 4 Adam Jackson 2008-10-15 13:51:50 EDT
(In reply to comment #3)

> What kernel/anaconda rev contained the patch you mention?

2.6.27-1.fc10 or later:

* Thu Oct 09 2008 Peter Jones <pjones@redhat.com>
- Fix the return code CD accesses when the CDROM drive door is closed
  but the drive isn't yet ready.
Comment 5 Will Woods 2008-10-23 15:30:40 EDT
This should be fixed in the next anaconda build (anaconda-11.4.1.51). I've tested with a test build and it worked as expected.

Note You need to log in before you can comment on or make changes to this bug.