Bug 456338 - unable to run yum update because blam need gecko-libs 1.9
unable to run yum update because blam need gecko-libs 1.9
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: blam (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-22 18:55 EDT by Christian Lupien
Modified: 2008-07-22 23:23 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.8.5-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-22 23:23:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Lupien 2008-07-22 18:55:03 EDT
Since the latest firefox update as been available (firefox.i386 0:3.0.1-1.fc9,
xulrunner-devel.i386 0:1.9.0.1-1.fc9) I have been unable to fully update my
system because blam (along with other programs) seems to require gecko-libs 1.9
and will not accept the new 1.9.0.1

The seem to be the same problem that affected gxine, see bug #455923

The package needs to be rebuilt with the new libs and might need relaxed
dependencies.
Comment 1 Alex Lancaster 2008-07-22 23:21:31 EDT
It's been pending for a couple of days now:

https://admin.fedoraproject.org/updates/F9/pending/blam-1.8.5-1.fc9

as has the Miro release but no pushes have gone out recently (don't know why no
updates have been pushed recently especially with all the breakage caused by the
xulrunner update).

Relaxed dependencies aren't really an option with any package that uses
gecko-devel-unstable (as blam does) because you can't guarantee that the API
won't change and therefore require a rebuild.

Note You need to log in before you can comment on or make changes to this bug.