Bug 456342 - utrace: stop-attach-then-wait testcase FAILs
utrace: stop-attach-then-wait testcase FAILs
Status: CLOSED DUPLICATE of bug 481199
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Oleg Nesterov
Red Hat Kernel QE team
http://sources.redhat.com/cgi-bin/cvs...
: Regression
Depends On: 454156
Blocks: 533192 525215
  Show dependency treegraph
 
Reported: 2008-07-22 19:46 EDT by Jan Kratochvil
Modified: 2011-02-02 13:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-02 13:52:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2008-07-22 19:46:36 EDT
+++ This bug was initially created as a clone of Bug #454156 +++

Description of problem:
Process SIGSTOPs, debugger PTRACE_ATTACHes it, first WAITPID(,,0) returns
SIGSTOP but second WAITPID(,,0) returns SIG_0 (that one should be waiting).

Version-Release number of selected component (if applicable):
FAIL kernel-2.6.18-92.1.6.el5.x86_64
(but PASS on RHEL-4 kernel-smp-2.6.9-67.0.20.EL.x86_64)

How reproducible:
Always.

Steps to Reproduce:
wget -O stop-attach-then-wait.c
http://sources.redhat.com/cgi-bin/cvsweb.cgi/~checkout~/tests/ptrace-tests/tests/stop-attach-then-wait.c?cvsroot=systemtap;
gcc -o stop-attach-then-wait stop-attach-then-wait.c -Wall -ggdb2 -D_GNU_SOURCE;
./stop-attach-then-wait; echo $?

Actual results:
1

Expected results:
0

Additional info:
Upstream bugreport post:
https://www.redhat.com/archives/utrace-devel/2008-June/msg00021.html
Comment 1 RHEL Product and Program Management 2008-07-25 13:01:11 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Ludek Smid 2008-07-25 17:53:58 EDT
Unfortunately the previous automated notification about the
non-inclusion of this request in Red Hat Enterprise Linux 5.3 used
the wrong text template. It should have read: this request has been
reviewed by Product Management and is not planned for inclusion
in the current minor release of Red Hat Enterprise Linux.

If you would like this request to be reviewed for the next minor
release, ask your support representative to set the next rhel-x.y
flag to "?" or raise an exception.
Comment 3 Jan Kratochvil 2008-07-29 04:53:06 EDT
It is a regression against RHEL-4.
I was unable to fix the Bug 456333 regressing issue 78487 as I was hitting this
Bug while coding it.
Comment 4 RHEL Product and Program Management 2008-07-29 04:56:58 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 5 Eric Bachalo 2008-11-25 14:13:57 EST
Pushing to RHEL 5.4, as this problem was not fixed for this release due to lower priority compared to other issues.
Comment 6 RHEL Product and Program Management 2008-11-25 14:42:00 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 9 RHEL Product and Program Management 2009-02-16 10:41:20 EST
Updating PM score.
Comment 13 Oleg Nesterov 2011-02-01 14:06:07 EST
Well. I need to reserve the testing machine to verify.

But. I bet this was already fixed, and this bug duplicates
bz #481199
Comment 14 Oleg Nesterov 2011-02-02 13:52:22 EST
(In reply to comment #13)
> Well. I need to reserve the testing machine to verify.
> 
> But. I bet this was already fixed, and this bug duplicates
> bz #481199

Yes, verified. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 481199 ***

Note You need to log in before you can comment on or make changes to this bug.