Bug 456412 - sat511 contains newer versions of rhn-solaris-bootstrap than sat520
sat511 contains newer versions of rhn-solaris-bootstrap than sat520
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
520
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Pazdziora
Jeff Browning
:
Depends On:
Blocks: 446866
  Show dependency treegraph
 
Reported: 2008-07-23 08:44 EDT by Milan Zázrivec
Modified: 2008-11-05 13:41 EST (History)
1 user (show)

See Also:
Fixed In Version: sat520
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 13:41:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2008-07-23 08:44:08 EDT
Description of problem:
Satellite 5.1.1 currently contains newer versions of rhn-solaris-bootstrap
than Satellite-5.2.0 (looking at a recently built satellite snapshot).

Steps to Reproduce:
1. Log into a machine with satellite 5.1.1 installed
2. # rpm -qa|grep rhn-solaris
3. Log into a machine with satellite 5.2.0 installed
4. # rpm -qa|grep rhn-solaris
  
Actual results:
* we are on a machine with satellite 5.1.1:
$ rpm -qa|grep solaris
rhn_solaris_bootstrap_5_1_1_3-1-0
rhn-solaris-bootstrap-5.1.1-3

* we are on a machine with satellite 5.2.0:
$ rpm -qa|grep solaris
rhn-solaris-bootstrap-5.1.0-3
rhn_solaris_bootstrap_5_1_0_3-1-0

Expected results:
Satellite 5.2.0 has to contain at least the same version of
rhn-solaris-bootstrap* packages as satellite 5.1.1.
Comment 1 Jan Pazdziora 2008-07-28 04:14:58 EDT
The ticket https://engineering.redhat.com/rt3/Ticket/Display.html?id=26028 to
get the packages imported to brew was filed with release-engineering on July 23rd.
Comment 2 Jan Pazdziora 2008-08-08 09:49:29 EDT
The packages cannot be imported (or they wouldn't be useful) because we need an extra package for .el4 and ahother one for .el5, because of different signature keys.

Therefore, copied cvs.devel.redhat.com:/cvs/rhn/solaris/bootstrap to branches/eng/RELEASE-5.2/solaris/bootstrap, and polished the .spec, ready to build new rpms.
Comment 3 Jan Pazdziora 2008-08-08 11:33:45 EDT
Built rhn-solaris-bootstrap-5.2.0-1.el[45] and rhn_solaris_bootstrap_5_2_0_1-1-0.el[45], tagged.
Comment 4 Brad Buckingham 2008-08-13 12:52:33 EDT
Mass move to ON_QA.
Comment 5 Jeff Browning 2008-08-15 15:26:12 EDT
Verified.

# rpm -qa|grep rhn-solaris
rhn-solaris-bootstrap-5.2.0-2.el5
Comment 6 Preethi Thomas 2008-10-22 10:07:18 EDT
release pending
Comment 7 Brandon Perkins 2008-11-05 13:41:18 EST
5.2.0 Satellite is now GA, bugs Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.