This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 456424 - gnome-appearance-properties failed to start
gnome-appearance-properties failed to start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker F10Alpha/F10AlphaBlocker
  Show dependency treegraph
 
Reported: 2008-07-23 10:18 EDT by CAI Qian
Modified: 2008-07-30 16:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 16:38:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2008-07-23 10:18:18 EDT
Description of problem:
$ gnome-appearance-properties 

(gnome-appearance-properties:26563): atk-bridge-WARNING **: AT_SPI_REGISTRY was
not started at session startup.

(gnome-appearance-properties:26563): atk-bridge-WARNING **: IOR not set.

(gnome-appearance-properties:26563): atk-bridge-WARNING **: Could not locate
registry

** (gnome-appearance-properties:26563): CRITICAL **:
dbus_g_connection_get_connection: assertion `gconnection' failed
process 26563: arguments to dbus_connection_send() were incorrect, assertion
"connection != NULL" failed in file dbus-connection.c line 3092.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted (core dumped)

$ gdb /usr/bin/gnome-appearance-properties core.26563
Core was generated by `gnome-appearance-properties'.
Program terminated with signal 6, Aborted.
[New process 26563]
#0  0x00007fae6cdbeee5 in raise (sig=<value optimized out>) at
../nptl/sysdeps/unix/sysv/linux/raise.c:64
64        return INLINE_SYSCALL (tgkill, 3, pid, selftid, sig);
Missing separate debuginfos, use: debuginfo-install GConf2.x86_64 ORBit2.x86_64
PolicyKit-gnome.x86_64 PolicyKit.x86_64 alsa-lib.x86_64 at-spi.x86_64 atk.x86_64
audiofile.x86_64 avahi.x86_64 cairo.x86_64 dbus-glib.x86_64 dbus.x86_64
e2fsprogs.x86_64 esound.x86_64 expat.x86_64 fontconfig.x86_64 freetype.x86_64
glib2.x86_64 gnome-desktop.x86_64 gnome-keyring.x86_64 gnome-menus.x86_64
gnome-panel.x86_64 gnome-vfs2.x86_64 gtk-nodoka-engine.x86_64 gtk2.x86_64
keyutils.x86_64 krb5.x86_64 libICE.x86_64 libSM.x86_64 libX11.x86_64
libXau.x86_64 libXcomposite.x86_64 libXcursor.x86_64 libXdamage.x86_64
libXdmcp.x86_64 libXext.x86_64 libXfixes.x86_64 libXft.x86_64 libXi.x86_64
libXinerama.x86_64 libXrandr.x86_64 libXrender.x86_64 libXtst.x86_64
libart_lgpl.x86_64 libbonobo.x86_64 libbonoboui.x86_64 libcap.x86_64
libgail-gnome.x86_64 libglade2.x86_64 libgnome.x86_64 libgnomecanvas.x86_64
libgnomeui.x86_64 libpng.x86_64 libselinux.x86_64 libxcb.x86_64 libxml2.x86_64
metacity.x86_64 openssl.x86_64 pango.x86_64 pixman.x86_64 popt.x86_64
startup-notification.x86_64 zlib.x86_64
(gdb) bt
#0  0x00007fae6cdbeee5 in raise (sig=<value optimized out>) at
../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007fae6cdc0a53 in abort () at abort.c:88
#2  0x00007fae6f3b7a05 in ?? () from /lib64/libdbus-1.so.3
#3  0x00007fae6f3b383d in ?? () from /lib64/libdbus-1.so.3
#4  0x00007fae6f39ddf9 in dbus_connection_send () from /lib64/libdbus-1.so.3
#5  0x00007fae6f397dd2 in dbus_bus_remove_match () from /lib64/libdbus-1.so.3
#6  0x00007fae700a7e10 in ?? () from /usr/lib64/libpolkit-gnome.so.0
#7  0x00007fae6d80e848 in g_object_unref () from /lib64/libgobject-2.0.so.0
#8  0x00007fae700a7ad3 in polkit_gnome_context_get () from
/usr/lib64/libpolkit-gnome.so.0
#9  0x00007fae700a86af in ?? () from /usr/lib64/libpolkit-gnome.so.0
#10 0x00007fae700aa038 in ?? () from /usr/lib64/libpolkit-gnome.so.0
#11 0x00007fae6d812090 in ?? () from /lib64/libgobject-2.0.so.0
#12 0x00007fae700aa0a9 in ?? () from /usr/lib64/libpolkit-gnome.so.0
#13 0x00007fae6d812640 in g_object_newv () from /lib64/libgobject-2.0.so.0
#14 0x00007fae6d8130ab in g_object_new_valist () from /lib64/libgobject-2.0.so.0
#15 0x00007fae6d8132fc in g_object_new () from /lib64/libgobject-2.0.so.0
#16 0x00007fae700a8ae7 in polkit_gnome_action_new_default () from
/usr/lib64/libpolkit-gnome.so.0
#17 0x0000000000410d02 in desktop_init (data=0x196faa0, uris=<value optimized
out>) at appearance-desktop.c:1170
#18 0x0000000000414302 in main (argc=1, argv=0x7fff7a69ad08) at
appearance-main.c:152


Version-Release number of selected component (if applicable):
Rawhide-20080720-tree-x86_64

control-center-2.23.4-4.fc10.x86_64
dbus-libs-1.2.1-6.fc10.x86_64
dbus-glib-0.76-1.fc10.x86_64
dbus-x11-1.2.1-6.fc10.x86_64
dbus-1.2.1-6.fc10.x86_64
atk-1.22.0-1.fc9.x86_64
PolicyKit-gnome-libs-0.8-5.fc10.x86_64
glib2-2.17.3-3.fc10.x86_64

How reproducible:
Always
Comment 1 Matthias Clasen 2008-07-24 23:38:15 EDT
Most likely a side-effect of gnome-session brokenness.

Can you reproduce this with gnome-session-2.23.5-0.2008.07.21.4.fc10 ?
Comment 2 CAI Qian 2008-07-25 07:02:20 EDT
Where could I find this package? I did not see it available on rawhide yet.
Comment 3 Bastien Nocera 2008-07-25 07:16:13 EDT
http://koji.fedoraproject.org/koji/packageinfo?packageID=315
Follow the links.
Comment 4 CAI Qian 2008-07-25 08:18:28 EDT
Same problem here,

[qcai@walsinh ~]$ gnome-appearance-properties 

** (gnome-appearance-properties:1468): CRITICAL **:
dbus_g_connection_get_connection: assertion `gconnection' failed
process 1468: arguments to dbus_connection_send() were incorrect, assertion
"connection != NULL" failed in file dbus-connection.c line 3092.
This is normally a bug in some application using the D-Bus library.
  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted (core dumped)

[qcai@walsinh ~]$ rpm -qa | grep gnome-session
gnome-session-2.23.5-0.2008.07.21.4.fc10.x86_64
Comment 5 Bill Nottingham 2008-07-30 16:38:04 EDT
This works for me in both rawhide and the current test Alpha live images. Please
reopen if it still fails for you.

Note You need to log in before you can comment on or make changes to this bug.