Bug 456461 - /sbin/loader(mountNfsImage+0x504)[0x100196d4]
/sbin/loader(mountNfsImage+0x504)[0x100196d4]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-23 16:25 EDT by James Laska
Modified: 2013-09-02 02:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 16:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-07-23 16:25:25 EDT
While attempting an NFS install using anaconda-11.4.1.15-1 against
http://porkchop.redhat.com/rawhide/nightly/rawhide-20080721/ppc/os I get the
following error from loader:

loader received SIGABRT!  Backtrace:                                           
/sbin/loader(loaderSegvHandler+0xa0)[0x10008100]
[0x100364]
[0xffd2a578]
/lib/libc.so.6(abort+0x260)[0xf8d1590]
/lib/libc.so.6[0xf91ba0c]
/lib/libc.so.6(cfree+0x48)[0xf91df08]
/sbin/loader(mountNfsImage+0x504)[0x100196d4]
/sbin/loader(main+0x9c4)[0x100094c4]
/lib/libc.so.6[0xf8b5ac4]
/lib/libc.so.6[0xf8b5c80]
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
you may safely reboot your system


I should note that loader seemed confused with the mount path and at one point
appended "images/stage.img" to the directory.  After manually removing that
text, it accepted the value and proceeded to the segfault above.
Comment 1 James Laska 2008-07-23 16:26:06 EDT
[Jul 23 16:25:01] <clumens> | if you want to be really helpful, you can mention
that nfsinstall.c:166 is the troublesome line
[Jul 23 16:25:10] <clumens> | which looks like this:  free(((struct
nfsInstallData *) loaderData->stage2Data)->directory);
[Jul 23 16:25:23] <clumens> | that way i don't have to eu-addr2line again :)
Comment 2 Chris Lumens 2008-07-23 17:19:47 EDT
I don't think it's possible to hit this segfault anymore, so please try
anaconda-11.4.1.18-1 and let me know.  I tried a couple different cmdline
parameters here and wasn't able to trigger the segfault though I was still going
through the same code path.
Comment 3 James Laska 2008-07-24 15:47:00 EDT
Tested (this time with kickstart) using anaconda-11.4.1.18-1 against
http://porkchop.redhat.com/rawhide/nightly/rawhide-20080724/ppc/os 

loader received SIGABRT!  Backtrace:
/sbin/loader(loaderSegvHandler+0xa0)[0x100081e0]
[0x100364]
[0xfff2e568]
/lib/libc.so.6(abort+0x260)[0xf8d1590]
/sbin/loader(setKickstartNfs+0x360)[0x100190f0]
/sbin/loader(runKickstart+0x9c)[0x100117cc]
/sbin/loader(main+0x17a4)[0x1000a384]
/lib/libc.so.6[0xf8b5ac4]
/lib/libc.so.6[0xf8b5c80]
install exited abnormally [1/1] 

We can close this one out and do a NEW (or DUP) bz if this is a different issue.
Comment 4 Chris Lumens 2008-07-24 16:38:34 EDT
Ah, this is because I actually need to check the return value of asprintf.  This
will be fixed in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.