Bug 456508 - Consolehelper breaks assistive technology support
Consolehelper breaks assistive technology support
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: usermode (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-24 05:50 EDT by Vladimir Benes
Modified: 2008-12-05 11:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-05 11:05:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2008-07-24 05:50:40 EDT
Description of problem:
consolehelper breaks accessibility.. all these packages listed here
http://intranet.corp.redhat.com/ic/intranet/DogtailUsabilityList.html (marked
with *) are assistive technology capable but because they use consolehelper our
tools based on at-spi technology cannot see applications widget/action structure
(accerciser, sniff).

Version-Release number of selected component (if applicable):
1.88-3.el5.1.i386 but also 1.96.1-1.x86_64 from fedora

How reproducible:


Steps to Reproduce:
1.switch on assistive technology in GNOME and restart X
2.run sniff (dogtail rpm) - has to be run as the same user as target app will run
3.run application from that list I mentioned above 
4.run the same application via its original command (i.e. 
/usr/sbin/system-config-boot)
  
Actual results:
app structure cannot be seen in at-spi tools

Expected results:
see app structure in at-spi tools

Additional info:
Comment 1 Miloslav Trmač 2008-12-05 10:18:48 EST
If I configure consolehelper to pass the GTK_MODULES=gail:atk-bridge environment variable, the application still doesn't register to the user's AT-SPI registry; instead, apparently because it runs as root, it uses a separate bonobo-activation server and at-spi-registryd, both running as root.

Matthias, is there a way to let the application running as root use the user's ORBit2/bonobo servers? Using the unprivileged user's ORBIT_SOCKETDIR value doesn't help.

Vladimir, as a workaround you can usually simply start both dogtail and the tested application as root without using consolehelper, by running PROGRAM from /etc/security/console.apps/$your_application instead of /usr/bin/$your_application.
Comment 2 Matthias Clasen 2008-12-05 10:58:20 EST
I have never investigated what it would take to make root processes use a users a11y infrastructure, because running the gui as root is just wrong. We have a framework to get away from that with PolicyKit. Of course, that doesn't help on RHEL5...
Comment 3 Miloslav Trmač 2008-12-05 11:05:18 EST
Oh well, WONTFIX then.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.