Bug 456512 - preference support on im-chooser
preference support on im-chooser
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcin (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chung-Yen Chang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-07-24 06:20 EDT by Akira TAGOH
Modified: 2008-10-28 06:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 06:12:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2008-07-24 06:20:05 EDT
Description of problem:
im-chooser has a feature to bring up the preference program for Input Method. it
would be nice to have one for gcin as well, instead of having one in the panel menu.

Version-Release number of selected component (if applicable):
1.4.2-2.fc10

How reproducible:
always

Steps to Reproduce:
1.run im-chooser
2.select gcin
3.see the Input Method Preferences button
  
Actual results:
the state of the button is glay-masked.

Expected results:
the button should be active.

Additional info:
What you need to do is to add:

PREFERENCE_PROGRAM=/usr/bin/gcin-setup

to gcin.conf. and after that, .desktop file should be duplicate. that would be
better getting rid of .desktop file from the package since it could be brought
up from the menu on the gcin icon at the systray too.
Comment 1 Tony Fu 2008-09-09 23:08:37 EDT
requested by Jens Petersen (#27995)
Comment 2 Jens Petersen 2008-10-20 23:42:03 EDT
should be fixed in gcin-1.4.2-4.fc10
Comment 3 Akira TAGOH 2008-10-28 06:12:08 EDT
Looks good. thanks!

Note You need to log in before you can comment on or make changes to this bug.